Bug 1282766 - [abrt] claws-mail: sgpgme_sigstat_info_short(): claws-mail killed by SIGSEGV
[abrt] claws-mail: sgpgme_sigstat_info_short(): claws-mail killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: claws-mail (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3825e3e482846a46d49f2bffc68...
:
: 1279218 1292950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 06:05 EST by kakoskin
Modified: 2016-01-03 16:19 EST (History)
6 users (show)

See Also:
Fixed In Version: claws-mail-3.13.1-4.fc23 claws-mail-3.13.1-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 19:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (65.14 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: core_backtrace (17.42 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: dso_list (17.48 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: environ (1.60 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: maps (85.00 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: mountinfo (3.23 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: namespaces (85 bytes, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: open_fds (1.70 KB, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: proc_pid_status (1016 bytes, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
File: var_log_messages (310 bytes, text/plain)
2015-11-17 06:05 EST, kakoskin
no flags Details
Corrupted GPG public keyring reproducing this bug. (30.67 KB, application/octet-stream)
2015-11-18 05:26 EST, kakoskin
no flags Details
the original mail for the test-case (5.38 KB, application/x-gzip)
2015-11-18 06:22 EST, Michael Schwendt
no flags Details

  None (edit)
Description kakoskin 2015-11-17 06:05:13 EST
Description of problem:
I tried to open OpenPGP/MIME message (actually https://lists.fedoraproject.org/pipermail/devel/2015-November/216921.html) with pgpcore, pgpinline and pgpmime plugins in use. Message was displayed and status notification with locksymbol said "Luetaan viestiä" in Finnish, ie something like "Opening message". Then Claws crashed

Version-Release number of selected component:
claws-mail-3.12.0-1.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        claws-mail
crash_function: sgpgme_sigstat_info_short
executable:     /usr/bin/claws-mail
global_pid:     6143
kernel:         4.2.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 sgpgme_sigstat_info_short at sgpgme.c:229
 #1 update_signature_noticeview at mimeview.c:1072
 #2 mimeview_check_sig_thread_cb at mimeview.c:1173
 #7 g_main_context_iteration at gmain.c:3869
 #8 gtk_main_iteration at gtkmain.c:1356
 #9 threaded_run at imap-thread.c:427
 #10 imap_threaded_store at imap-thread.c:3270
 #11 imap_set_message_flags at imap.c:4368
 #13 imap_change_flags at imap.c:4955
 #15 folder_item_change_msg_flags at folder.c:3883
Comment 1 kakoskin 2015-11-17 06:05:21 EST
Created attachment 1095370 [details]
File: backtrace
Comment 2 kakoskin 2015-11-17 06:05:22 EST
Created attachment 1095371 [details]
File: cgroup
Comment 3 kakoskin 2015-11-17 06:05:24 EST
Created attachment 1095372 [details]
File: core_backtrace
Comment 4 kakoskin 2015-11-17 06:05:26 EST
Created attachment 1095373 [details]
File: dso_list
Comment 5 kakoskin 2015-11-17 06:05:28 EST
Created attachment 1095374 [details]
File: environ
Comment 6 kakoskin 2015-11-17 06:05:29 EST
Created attachment 1095375 [details]
File: limits
Comment 7 kakoskin 2015-11-17 06:05:32 EST
Created attachment 1095376 [details]
File: maps
Comment 8 kakoskin 2015-11-17 06:05:33 EST
Created attachment 1095377 [details]
File: mountinfo
Comment 9 kakoskin 2015-11-17 06:05:35 EST
Created attachment 1095378 [details]
File: namespaces
Comment 10 kakoskin 2015-11-17 06:05:36 EST
Created attachment 1095379 [details]
File: open_fds
Comment 11 kakoskin 2015-11-17 06:05:37 EST
Created attachment 1095380 [details]
File: proc_pid_status
Comment 12 kakoskin 2015-11-17 06:05:39 EST
Created attachment 1095381 [details]
File: var_log_messages
Comment 13 kakoskin 2015-11-17 06:15:02 EST
I was able to open said message normally after removing all pgp-plugins. After adding them back Claws was crashing constantly.
Comment 14 Michael Schwendt 2015-11-17 07:43:44 EST
Thanks for filing the bug report. There has been a similar one in bug 1279218 for Fedora 23, crashing in the same line of code, but with a different backtrace and no steps on how to reproduce it.

This one I cannot reproduce either. I've fetched the original message you refer to but it verifies fine.

More trouble-shooting is necessary.

[...]

Meanwhile I've done some searching. Debian has been affected, too:

  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=796870

However, the patch mentioned there has been reverted again in upstream git on
2015-11-01, called a "regression", which is *after* the release of 3.13.0:

  http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=22a0f60092f94e7228e7bf0817a6982ac8dd7a59
Comment 15 kakoskin 2015-11-18 05:24:30 EST
I have created minimal GPG public keyring that reproduces this bug. Keyring contains only two puclic keys that are currently available on keyservers.

Apparently there is some problems in how GPG updates to version 2 causing problematic keyrings. 

This worked for me also on Fedora 23. 

To reproduce using minimal-reproducer-gnupg.tar.gz:

1. Extract the tarball.
2. $export GNUPGHOME=<path to GNUPG-Corrupted>
3. $claws-mail
4. Open the email from original report. 

If you have to import new key to this keyring use command gpg --import, not gpg2 --import.
Comment 16 kakoskin 2015-11-18 05:26 EST
Created attachment 1095935 [details]
Corrupted GPG public keyring reproducing this bug.
Comment 17 Michael Schwendt 2015-11-18 06:19:09 EST
Great! That's sufficient to reproduce it.

Claws Mail 3.13.0 fixes it and prints

  The signature can't be checked - End of file.

instead.
Comment 18 Michael Schwendt 2015-11-18 06:22 EST
Created attachment 1095966 [details]
the original mail for the test-case
Comment 19 Michael Schwendt 2015-12-18 15:53:38 EST
*** Bug 1279218 has been marked as a duplicate of this bug. ***
Comment 20 Michael Schwendt 2015-12-18 16:10:56 EST
*** Bug 1292950 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2015-12-18 16:33:11 EST
claws-mail-3.13.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9a092f35d2
Comment 22 Fedora Update System 2015-12-19 14:58:32 EST
claws-mail-3.13.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update claws-mail'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa14be8d92
Comment 23 Fedora Update System 2015-12-20 18:30:31 EST
claws-mail-3.13.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa14be8d92
Comment 24 Fedora Update System 2015-12-21 00:29:07 EST
claws-mail-3.13.1-1.fc22.1 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9a092f35d2
Comment 25 Fedora Update System 2015-12-21 14:32:15 EST
claws-mail-3.13.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa14be8d92
Comment 26 Fedora Update System 2015-12-21 14:45:23 EST
claws-mail-3.13.1-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9a092f35d2
Comment 27 Fedora Update System 2015-12-22 07:05:34 EST
claws-mail-3.13.1-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3a073171c3
Comment 28 Fedora Update System 2015-12-22 10:34:05 EST
claws-mail-3.13.1-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9a092f35d2
Comment 29 Fedora Update System 2015-12-22 19:11:49 EST
claws-mail-3.13.1-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aa14be8d92
Comment 30 Fedora Update System 2015-12-26 18:52:18 EST
claws-mail-3.13.1-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3a073171c3
Comment 31 kakoskin 2015-12-28 16:34:25 EST
Version claws-mail-3.13.0-2 fixes this problem for me both in Fedora 22 and in Fedora 23.
Comment 32 Fedora Update System 2015-12-30 19:56:03 EST
claws-mail-3.13.1-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2016-01-03 16:19:27 EST
claws-mail-3.13.1-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.