Bug 1292950 - crash when viewing pgp signed message
crash when viewing pgp signed message
Status: CLOSED DUPLICATE of bug 1282766
Product: Fedora
Classification: Fedora
Component: claws-mail (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 15:06 EST by rstory
Modified: 2015-12-18 16:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 16:10:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rstory 2015-12-18 15:06:20 EST
Description of problem:
I just upgraded to F23 today, and claws-mail is very unstable. It seems that simply viewing a pgp signed message will crash. Most of my co-workers sign mail, which make claws-mail essentially unusable for me.

Version-Release number of selected component (if applicable):
claws-mail-3.12.0-1.fc23.x86_64

How reproducible:
very

Steps to Reproduce:
1. launch claws
2. click on pgp signed message to view
3. see claws crash

Actual results:
crash

Expected results:
no crash

Additional info:
stack trace:

#0  0x00007fffd3889d74 in sgpgme_sigstat_info_short (ctx=<optimized out>, status=<optimized out>) at sgpgme.c:229
#1  0x0000555555701603 in update_signature_noticeview (mimeview=mimeview@entry=0x55555603f440, mimeinfo=0x55555747eff0, special=special@entry=0, 
    code=code@entry=SIGNATURE_UNCHECKED) at mimeview.c:1072
#2  0x0000555555701fa4 in mimeview_check_sig_thread_cb (data=0x55555603f440) at mimeview.c:1173
#3  0x00007ffff391f893 in g_timeout_dispatch () from /lib64/libglib-2.0.so.0
#4  0x00007ffff391ee3a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#5  0x00007ffff391f1d0 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#6  0x00007ffff391f4f2 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#7  0x00007ffff704df37 in gtk_main () from /lib64/libgtk-x11-2.0.so.0
#8  0x0000555555665e7f in main (argc=1, argv=0x7fffffffdaf8) at main.c:1559
Comment 1 Michael Schwendt 2015-12-18 16:10:56 EST
see bug 1282766 comment 15

*** This bug has been marked as a duplicate of bug 1282766 ***

Note You need to log in before you can comment on or make changes to this bug.