Bug 1282818 - Cursor in Firefox running on XWayland is broken
Cursor in Firefox running on XWayland is broken
Status: CLOSED DUPLICATE of bug 1278316
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-11-17 09:21 EST by Jiri Eischmann
Modified: 2015-11-25 04:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 04:50:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Eischmann 2015-11-17 09:21:10 EST
The mouse cursor in Firefox running XWayland doesn't work correctly. It doesn't change according to objects it hovers over (sometimes it gets stuck with text input cursor) and it sometimes disappears completely (I can reproduce it with HTML5 videos, when I hover the cursor over the video element the cursor disappears and never appears again). This draws Firefox on XWayland unusable.

I'm using Firefox 42 and Xorg 1.18.
Comment 1 Juan Orti 2015-11-17 16:43:38 EST
I'm experiencing the same issue in applications running on XWayland.

Sometimes, the mouse cursor gets stuck with the wrong icon, like the resize window or text input. Other times it just disappears.

Versions:
ibus-wayland-1.5.11-1.fc23.x86_64
libwayland-client-1.9.0-1.fc23.x86_64
xorg-x11-server-Xwayland-1.18.0-1.fc23.x86_64
mesa-libwayland-egl-11.0.4-1.20151105.fc23.x86_64
libwayland-cursor-1.9.0-1.fc23.x86_64
libwayland-server-1.9.0-1.fc23.x86_64
gnome-session-wayland-session-3.18.1.2-2.fc23.x86_64
mutter-3.18.1-4.fc23.x86_64
Comment 2 Kamil Páral 2015-11-18 04:47:52 EST
I haven't yet seen issues described by OP, but I've noticed that a "wait" cursor (spinner) does not animate if you keep the cursor still, it only animates when you move the cursor. That can be easily seen here:
http://www.javascripter.net/faq/stylesc.htm
Move your cursor over the "wait" hyperlink - if you hold still, the spinner does not animate, but if you move it slightly left and right (while still hovering over the "wait" hyperlink), it animates.
Comment 3 Christian Stadelmann 2015-11-24 16:22:09 EST
This is a duplicate of #1278316
Comment 4 Kamil Páral 2015-11-25 04:50:43 EST

*** This bug has been marked as a duplicate of bug 1278316 ***

Note You need to log in before you can comment on or make changes to this bug.