This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282826 - hackbench: modify to run within NUMA node to avoid cross-node traffic
hackbench: modify to run within NUMA node to avoid cross-node traffic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rteval (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: 7.3
Assigned To: Clark Williams
Jiri Kastner
: ZStream
Depends On:
Blocks: 1274397 RT7.3-Prio 1284553 1284980
  Show dependency treegraph
 
Reported: 2015-11-17 09:39 EST by Clark Williams
Modified: 2016-11-03 21:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1284553 1284980 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:34:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to prevent hackbench generating cross-numa-node traffic (6.22 KB, patch)
2015-11-17 17:33 EST, Clark Williams
no flags Details | Diff

  None (edit)
Description Clark Williams 2015-11-17 09:39:09 EST
the hackbench load excercises memory allocation/free and memory copies. Originally rteval started it's loads across the entire set of cpus, but this is not consistent with good RT programming practice as it generates large amounts of cross-node memory traffic, which leads to latency spikes. 

Modify hackbench to run one instance for each numa node in the system, rather than one instance for the entire system.
Comment 1 Clark Williams 2015-11-17 17:33 EST
Created attachment 1095714 [details]
patch to prevent hackbench generating cross-numa-node traffic
Comment 6 errata-xmlrpc 2016-11-03 21:34:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2244.html

Note You need to log in before you can comment on or make changes to this bug.