Bug 1284553 - hackbench: modify to run within NUMA node to avoid cross-node traffic
hackbench: modify to run within NUMA node to avoid cross-node traffic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rteval (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Clark Williams
Network QE
: ZStream
Depends On: 1282826 1284980
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 10:02 EST by Jan Kurik
Modified: 2016-02-16 05:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The rteval tool uses the hackbench utility to place a load on the system to exercise memory allocation, free and memory copies. Prior to this update, rteval started its loads across the entire set of CPUs, which generated large amounts of cross-node memory traffic. As a consequence, latency spikes could occur. With this update, hackbench has been modified to run a single instance for each Non-Uniform Memory Acces (NUMA) node in the system to better reflect common system tuning for a real-time environment, and the latency spikes no longer occur.
Story Points: ---
Clone Of: 1282826
Environment:
Last Closed: 2016-02-16 05:13:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-23 10:02:20 EST
This bug has been copied from bug #1282826 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 7 errata-xmlrpc 2016-02-16 05:13:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0200.html

Note You need to log in before you can comment on or make changes to this bug.