Bug 1282963 - rhel-osp-director: 8.0 - deploying with VLAN network type: the vlan ranges provides with --neutron-network-vlan-ranges aren't written into /etc/neutron/plugin.ini.
rhel-osp-director: 8.0 - deploying with VLAN network type: the vlan ranges p...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Brad P. Crochet
Alexander Chuzhoy
: Regression, TestOnly, Triaged
: 1290598 (view as bug list)
Depends On:
Blocks: 1261979 1310828
  Show dependency treegraph
 
Reported: 2015-11-17 17:32 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:42 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:42:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
overcloud deployment log (177.79 KB, application/x-gzip)
2016-01-08 14:07 EST, Alexander Chuzhoy
no flags Details
the right overcloud deployment log (179.51 KB, application/x-gzip)
2016-01-08 15:02 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-11-17 17:32:05 EST
rhel-osp-director: 8.0 - deploying with VLAN network type:  the vlan ranges provides with --neutron-network-vlan-ranges aren't written into /etc/neutron/plugin.ini.

Environment:
python-neutron-7.0.0-3.el7ost.noarch
openstack-neutron-7.0.0-3.el7ost.noarch
openstack-neutron-ml2-7.0.0-3.el7ost.noarch
openstack-neutron-common-7.0.0-3.el7ost.noarch
openstack-neutron-lbaas-7.0.0-2.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-metering-agent-7.0.0-3.el7ost.noarch
openstack-neutron-openvswitch-7.0.0-3.el7ost.noarch
instack-undercloud-2.1.3-1.el7ost.noarch


Steps to reproduce:
1. Deploy overcloud with --neutron-network-type vlan --neutron-bridge-mappings datacentre:br-ex  --neutron-network-vlan-ranges datacentre:<range>  --neutron-disable-tunneling

2. Login to one controller and check the network_vlan_ranges line in /etc/neutron/plugin.ini file.

Result:
network_vlan_ranges =datacentre


Expected result:
network_vlan_ranges =datacentre:<range>
Comment 2 Assaf Muller 2015-12-23 18:21:19 EST
For the record this means that you can't install OpenStack using VLAN tenant networks, nothing will work.
Comment 3 Mike Burns 2016-01-07 14:22:06 EST
*** Bug 1290598 has been marked as a duplicate of this bug. ***
Comment 4 Brad P. Crochet 2016-01-07 16:31:17 EST
Please provide a log of the deployment.
Comment 5 Alexander Chuzhoy 2016-01-08 14:07 EST
Created attachment 1112963 [details]
overcloud deployment log
Comment 6 Alexander Chuzhoy 2016-01-08 15:02 EST
Created attachment 1112973 [details]
the right overcloud deployment log
Comment 7 Nick Satsia 2016-01-31 06:55:11 EST
Ran into this issue with OSP8-beta5 and director-beta2

I notice in /etc/neutron/plugin.ini that not only the vlan range is missing but the network name is also wrong. Still show "datacenter" instead of "tenant" that I specified.

Deployed with:
.
.
 --neutron-disable-tunneling \
 --neutron-network-type vlan \
 --neutron-network-vlan-ranges tenant:2101:2199 \
 --neutron-flat-networks datacenter,sdn,tenant \
 --neutron-bridge-mappings datacenter:br-ex,sdn:br-trunk-sdn,tenant:br-trunk-tenant


plugin.ini snip:
[ml2_type_flat]
# (ListOpt) List of physical_network names with which flat networks
# can be created. Use * to allow flat networks with arbitrary
# physical_network names.
#
# flat_networks =
flat_networks =datacenter,sdn,tenant
# Example:flat_networks = physnet1,physnet2
# Example:flat_networks = *

[ml2_type_vlan]
# (ListOpt) List of <physical_network>[:<vlan_min>:<vlan_max>] tuples
# specifying physical_network names usable for VLAN provider and
# tenant networks, as well as ranges of VLAN tags on each
# physical_network available for allocation as tenant networks.
#
# network_vlan_ranges =
network_vlan_ranges =datacentre
# Example: network_vlan_ranges = physnet1:1000:2999,physnet2
Comment 8 Brad P. Crochet 2016-02-05 08:46:58 EST
This appears to be fixed in the latest poodle.

[ml2_type_flat]
# (ListOpt) List of physical_network names with which flat networks
# can be created. Use * to allow flat networks with arbitrary
# physical_network names.
#
# flat_networks =
flat_networks =datacenter,sdn,tenant
# Example:flat_networks = physnet1,physnet2
# Example:flat_networks = *

[ml2_type_vlan]
# (ListOpt) List of <physical_network>[:<vlan_min>:<vlan_max>] tuples
# specifying physical_network names usable for VLAN provider and
# tenant networks, as well as ranges of VLAN tags on each
# physical_network available for allocation as tenant networks.
#
# network_vlan_ranges =
network_vlan_ranges =tenant:2101:2199
# Example: network_vlan_ranges = physnet1:1000:2999,physnet2
Comment 9 Alexander Chuzhoy 2016-02-24 14:34:33 EST
Verified:
Environment:
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-puppet-modules-7.0.6-2.el7ost.noarch

openstack-neutron-common-7.0.1-10.el7ost.noarch
openstack-neutron-ml2-7.0.1-10.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-10.el7ost.noarch
openstack-neutron-7.0.1-10.el7ost.noarch
Deployed with:
 --neutron-network-vlan-ranges datacentre:118:143

The /etc/neutron/plugin.ini file has:
network_vlan_ranges =datacentre:118:143
Comment 11 errata-xmlrpc 2016-04-07 17:42:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.