Bug 1290598 - VLAN range not configured in neutron/plugin.ini
VLAN range not configured in neutron/plugin.ini
Status: CLOSED DUPLICATE of bug 1282963
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Jay Dobies
yeylon@redhat.com
:
Depends On:
Blocks: 1261979
  Show dependency treegraph
 
Reported: 2015-12-10 17:59 EST by Chris Dearborn
Modified: 2016-04-18 02:59 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 14:22:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Dearborn 2015-12-10 17:59:26 EST
Description of problem:
After deploying the overcloud with neutron in vlan mode, "neutron net-create foo" fails with:
Unable to create the network. No tenant network is available for allocation.

I spent some time investigating this, and it turned out that the vlan range I specified in the deploy command was not in the neutron config.  In /etc/neutron/plugin.ini was this line:
network_vlan_ranges =datacentre

On all controllers, I changed this to:
network_vlan_ranges =datacentre:201:220
then restarted the controllers, and was able to create networks successfully.

The command used to deploy was:

openstack overcloud deploy -t 90 --templates ~/pilot/templates/overcloud -e ~/pilot/templates/network-environment.yaml -e ~/pilot/templates/overcloud/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml --control-scale 3 --control-flavor controller --compute-flavor compute --ceph-storage-flavor storage --swift-storage-flavor storage --block-storage-flavor storage --neutron-public-interface bond1 --neutron-network-type vlan --neutron-disable-tunneling --compute-scale 3 --ceph-storage-scale 3 --ntp-server 0.centos.pool.ntp.org --neutron-network-vlan-ranges datacentre:201:220


Version-Release number of selected component (if applicable):
8.0 Beta 2

How reproducible:
Deploy the overcloud with neutron using vlans as above.

Steps to Reproduce:
See above.

Actual results:
VLAN range was not configured in neutron

Expected results:
VLAN range should be configured in neutron.

Additional info:
Comment 2 Mike Burns 2016-01-07 14:22:06 EST

*** This bug has been marked as a duplicate of bug 1282963 ***

Note You need to log in before you can comment on or make changes to this bug.