Bug 1283032 - While file is self healing append to the file hangs
While file is self healing append to the file hangs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1282747
Blocks: 1283478
  Show dependency treegraph
 
Reported: 2015-11-17 23:32 EST by Ravishankar N
Modified: 2016-06-16 09:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282747
: 1283478 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:44:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-11-17 23:32:21 EST
+++ This bug was initially created as a clone of Bug #1282747 +++

Description of problem:
============
While file is self healing append to the file hangs 


Version-Release number of selected component (if applicable):
=========
glusterfs-server-3.7.5-6


How reproducible:


Steps to Reproduce:
=============
1. Create 1x2 volume and mount it on client using fuse 
2. Bring down one of the brick and create a big file 2 GB
3. Bring back the down brick and while self heal is going on try to append it to the file but it hangs untill self heal completes 

Actual results:


Expected results:
===========
Append to the file should complete without hangs
Comment 1 Vijay Bellur 2015-11-17 23:33:44 EST
REVIEW: http://review.gluster.org/12602 (afr: Drop compatibility lock for data self-heal) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-11-18 14:34:40 EST
COMMIT: http://review.gluster.org/12602 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 4b8249a35aba28621ed59155ab27fb5bfa5f113f
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Nov 18 08:30:48 2015 +0530

    afr: Drop compatibility lock for data self-heal
    
    In glusterfs 3.4 and older, AFR did not take locks in self-heal domain
    during data self-heal. So this compat lock in data domain was added to prevent
    older clients from trying to heal a file while an existing self-heal was going
    on by a newer client. But the side effect was that all appending writes (which
    take full locks in data domain) from mounts would be stalled until self-heal
    was complete.
    
    Since glusterfs 3.4 is not supported anymore, remove the compat lock.
    
    Change-Id: I31c8e4d7f3364f769a14eec295154e3c40d9f78e
    BUG: 1283032
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12602
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 09:44:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.