Bug 1283478 - While file is self healing append to the file hangs
While file is self healing append to the file hangs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1282747 1283032
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 00:22 EST by Ravishankar N
Modified: 2016-04-19 03:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283032
Environment:
Last Closed: 2016-02-18 23:44:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-11-19 00:22:49 EST
+++ This bug was initially created as a clone of Bug #1283032 +++

+++ This bug was initially created as a clone of Bug #1282747 +++

Description of problem:
============
While file is self healing append to the file hangs 


Version-Release number of selected component (if applicable):
=========
glusterfs-server-3.7.5-6


How reproducible:


Steps to Reproduce:
=============
1. Create 1x2 volume and mount it on client using fuse 
2. Bring down one of the brick and create a big file 2 GB
3. Bring back the down brick and while self heal is going on try to append it to the file but it hangs untill self heal completes 

Actual results:


Expected results:
===========
Append to the file should complete without hangs
Comment 1 Vijay Bellur 2015-11-19 00:30:12 EST
REVIEW: http://review.gluster.org/12653 (afr: Drop compatibility lock for data self-heal) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-11-19 22:50:05 EST
REVIEW: http://review.gluster.org/12653 (afr: Drop compatibility lock for data self-heal) posted (#2) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2015-11-23 02:01:45 EST
REVIEW: http://review.gluster.org/12653 (afr: Drop compatibility lock for data self-heal) posted (#3) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 4 Vijay Bellur 2015-11-23 13:59:40 EST
COMMIT: http://review.gluster.org/12653 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit f46a54326871bed28c64cd5312b250c7c8207e4f
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Nov 18 08:30:48 2015 +0530

    afr: Drop compatibility lock for data self-heal
    
    Backport of http://review.gluster.org/#/c/12602/
    
    In glusterfs 3.4 and older, AFR did not take locks in self-heal domain
    during data self-heal. So this compat lock in data domain was added to prevent
    older clients from trying to heal a file while an existing self-heal was going
    on by a newer client. But the side effect was that all appending writes (which
    take full locks in data domain) from mounts would be stalled until self-heal
    was complete.
    
    Since glusterfs 3.4 is not supported anymore, remove the compat lock.
    
    Change-Id: I20bb2edf7527ce5d8291d13eb8b9149e66e9bcac
    BUG: 1283478
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12653
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Ravishankar N 2016-02-18 23:44:16 EST
v3.7.7 contains a fix.
Comment 6 Kaushal 2016-04-19 03:48:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.