Bug 1283105 - Error 500 InternalServerError refreshing relationship and power state
Summary: Error 500 InternalServerError refreshing relationship and power state
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.5.0
Assignee: Greg Blomquist
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-18 09:39 UTC by Ronnie Rasouli
Modified: 2015-11-24 17:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 17:10:27 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
evm.log while reproducing the issue (160.52 KB, text/plain)
2015-11-18 09:39 UTC, Ronnie Rasouli
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1282253 None CLOSED Error: Unable to retrieve volume limit information when accessing System Defaults in Horizon 2019-11-10 18:03:48 UTC

Description Ronnie Rasouli 2015-11-18 09:39:50 UTC
Created attachment 1095917 [details]
evm.log while reproducing the issue

Description of problem:

Got error in refreshing provider  Expected(200) <=> Actual(500 InternalServerError) excon.error.response :body => "{\"computeFault\": {\"mes... 
Installed via director 8.0.0-1.el7os

Version-Release number of selected component (if applicable):

5.5.0.10-beta2.1.20151110134042_d6f5459

How reproducible:
Always reproduced

Steps to Reproduce:
1.login CFME
2.create new provider: cloud -> provider-> configuration-> add new cloud provider
3.configure controller IP and admin password of overcloud
4. refresh by: Configuration-> Refresh relationship and power state
5. refresh browser

Actual results:
Error -> refresh failed
Error - About 2 Hours Ago
Expected(200) <=> Actual(500 InternalServerError) excon.error.response :body => "{\"computeFault\": {\"mes... 


Expected results:
refresh success and all overclouds nodes will be presented

Additional info:
seems like cinder v2 is default in CLIs
Attached evm.log from reproducing the issue
From remote host to controller
curl http://192.0.2.8:8776/V2
{"choices": [{"status": "SUPPORTED", "media-types": [{"base": "application/xml", "type": "application/vnd.openstack.volume+xml;version=1"}, {"base": "application/json", "type": "application/vnd.openstack.volume+json;version=1"}], "id": "v1.0", "links": [{"href": "http://192.0.2.8:8776/v1/V2", "rel": "self"}]}, {"status": "CURRENT", "media-types": [{"base": "application/xml", "type": "application/vnd.openstack.volume+xml;version=1"}, {"base": "application/json", "type": "application/vnd.openstack.volume+json;version=1"}], "id": "v2.0", "links": [{"href": "http://192.0.2.8:8776/v2/V2", "rel": "self"}]}]}

Comment 2 Ladislav Smola 2015-11-18 11:37:58 UTC
This issue is probably caused by missing cinder in endpoints. Seems there is still api request to quotas.

Comment 3 Ladislav Smola 2015-11-18 12:11:47 UTC
hm the problem is that this doesn't work

cinder --os-volume-api-version 1 quota-show 3279b55051a445dfaec22b4e76481c18

or 

cinder quota-show 3279b55051a445dfaec22b4e76481c18

CFME relies on this API to work, so there is something wrong with the openstack

@Ronnie probably close it as not a bug

Comment 4 Dave Johnson 2015-11-24 17:10:27 UTC
@Ronnie, please reopen if you disagree with Ladislav but I am closing this as not a bug.


Note You need to log in before you can comment on or make changes to this bug.