Bug 1282253 - Error: Unable to retrieve volume limit information when accessing System Defaults in Horizon
Error: Unable to retrieve volume limit information when accessing System Defa...
Status: CLOSED DUPLICATE of bug 1272572
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Jiri Stransky
yeylon@redhat.com
:
Depends On: 1272572 1290415
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-15 14:42 EST by Marius Cornea
Modified: 2016-04-18 03:13 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272572
Environment:
Last Closed: 2016-01-27 05:42:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 239109 None None None Never

  None (edit)
Description Marius Cornea 2015-11-15 14:42:36 EST
+++ This bug was initially created as a clone of Bug #1272572 +++

Description of problem:
When going to System->Defaults in Horizon an 'Error: Unable to retrieve volume limit information.' shows up. 
Cinder logs show the following:
2015-10-16 19:00:05.262 25704 ERROR cinder.api.middleware.fault [req-79120e7c-360e-4694-a132-e409c4edc2cb 81711f9c9eb24da292ed59647041c422 741b6051f5064e17a3418be64e6a3fcd - - -] Caught error: Authorization failed: Unable to establish connection to http://localhost:5000/v3/auth/tokens
 

Version-Release number of selected component (if applicable):
openstack-dashboard-8.0.0.0-rc1.el7.centos.noarch
python-django-horizon-8.0.0.0-rc1.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy one controller + one compute overcloud
2. Log in to Horizon
3. Go to System->Defaults

Actual results:
Error: Unable to retrieve volume limit information.

Expected results:
No error gets returned.

--- Additional comment from AliRezaTaleghani on 2015-10-18 06:00:01 EDT ---

I think I figure this out:

file: /usr/lib/python2.7/site-packages/cinder/keymgr/key_mgr.py
Line: 27


The default param on cinder key manager which was:
FROM :=> default='http://localhost:5000/v3',
TO:   => default='http://10.20.30.26:5000/v3',
and that was all....

but it's the default library value I thinks, and it should be possible to be overwrite on some configuration files i hope... (ex: /etc/cinder/api-paste.ini)

--- Additional comment from Dan Radez on 2015-10-23 15:33:24 EDT ---

I added:

[keymgr]
encryption_auth_url=http://192.0.2.6:5000/v3

to the end of /etc/cinder/cinder.conf and bounced the cinder-api service

This resolved the issue for me.
Comment 2 Marius Cornea 2015-11-15 14:48:16 EST
Version: openstack-tripleo-heat-templates-0.8.7-1.el7ost.noarch
Comment 3 Marius Cornea 2015-11-18 12:24:41 EST
This also impacts Cloudforms integration.
Comment 4 Udi 2016-01-25 12:37:20 EST
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1272572
Comment 5 Jaromir Coufal 2016-01-27 05:42:54 EST

*** This bug has been marked as a duplicate of bug 1272572 ***

Note You need to log in before you can comment on or make changes to this bug.