Bug 1283192 - Race condition on systemd-run --scope --slice=foo
Race condition on systemd-run --scope --slice=foo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
: ZStream
Depends On: 1272368
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 07:33 EST by Jan Kurik
Modified: 2016-02-16 05:40 EST (History)
16 users (show)

See Also:
Fixed In Version: systemd-219-19.el7.1
Doc Type: Bug Fix
Doc Text:
Under certain circumstances, by the time PID 1 adds a process to the scope unit, the process can already be ended if the process is short-running, for example an invocation to /bin/true. As a consequence, when the systemd service picked a recycled name for a scope, the following error could occur: 'Failed to start transient scope unit: Unit run-XXXXX.scope already exists.' To fix this bug, systemd-run synchronously waits until the scope unit that is being created is started.
Story Points: ---
Clone Of: 1272368
Environment:
Last Closed: 2016-02-16 05:40:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-18 07:33:04 EST
This bug has been copied from bug #1272368 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Branislav Blaškovič 2015-12-01 10:21:42 EST
This bug should no longer occour in systemd-219-19.el7_2.2. Stress test added as /CoreOS/systemd/Regression/scope-unit-stress-test

But I hit another bug: BZ#1287135. It does not have any fatal consequences, so switching to VERIFIED.
Comment 7 errata-xmlrpc 2016-02-16 05:40:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0199.html

Note You need to log in before you can comment on or make changes to this bug.