This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283202 - RFE: backport max monitor limitation from spice-server upstream
RFE: backport max monitor limitation from spice-server upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice (Show other bugs)
7.3
All Unspecified
high Severity medium
: rc
: 7.4
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
Jiri Herrmann
: FutureFeature
Depends On: 1283198 1388947
Blocks: 1075798 1283207 1395265
  Show dependency treegraph
 
Reported: 2015-11-18 07:47 EST by Frediano Ziglio
Modified: 2017-08-01 12:06 EDT (History)
11 users (show)

See Also:
Fixed In Version: spice-0.12.4-18.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:06:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frediano Ziglio 2015-11-18 07:47:06 EST
Description of problem:
This is to support https://bugzilla.redhat.com/show_bug.cgi?id=1075798 in newer RHEL version.


Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always.

Steps to Reproduce:
1. Try to set monitor number from interface (like virt-manager).
2. Open spice client
3. Try to open more monitors than configured number

Actual results:
Displays are opened without problems.

Expected results:
Failure and client should not even prompt for such setting.

Additional info:
Needs to backport to spice-serve commit 6d4e58f70ddf9c178e2cc20dd5a3ade8b95fd142. Better to move to spice-server 0.12.6.
Comment 2 Frediano Ziglio 2016-02-17 10:11:49 EST
Still waiting Desktop team to sort out libvirt issue.
Comment 4 Radek Duda 2016-07-18 09:08:12 EDT
For me it is not fixed. If I set number of heads=1 in libvirt xml file, the number of displays can be increased up to four in remote-viewer menu (rhel 7.3 VM). Windows 7 VM works correctly.

host/client rhel 7.3 nightly:
spice-server-0.12.4-18.el7.x86_64
virt-viewer-2.0-10.el7.x86_64
qemu-2.0.0-1.el7.6.x86_64
qemu-kvm-debuginfo-1.5.3-117.el7.x86_64
qemu-user-2.0.0-1.el7.6.x86_64
qemu-img-1.5.3-117.el7.x86_64
qemu-kvm-1.5.3-117.el7.x86_64
qemu-kvm-common-1.5.3-117.el7.x86_64

client rhel 7.3 nightly
spice-vdagent-0.14.0-14.el7.x86_64
spice-protocol-0.12.11-1.el7.noarch
spice-server-0.12.4-18.el7.x86_64
xorg-x11-drv-qxl-0.1.1-18.el7.x86_64
Comment 5 Pavel Grunt 2016-07-18 09:14:58 EDT
Hey, 

(In reply to Radek Duda from comment #4)
> For me it is not fixed. If I set number of heads=1 in libvirt xml file, the
> number of displays can be increased up to four in remote-viewer menu (rhel
> 7.3 VM). Windows 7 VM works correctly.
> 
> host/client rhel 7.3 nightly:
> spice-server-0.12.4-18.el7.x86_64
> virt-viewer-2.0-10.el7.x86_64
> qemu-2.0.0-1.el7.6.x86_64
> qemu-kvm-debuginfo-1.5.3-117.el7.x86_64
> qemu-user-2.0.0-1.el7.6.x86_64
> qemu-img-1.5.3-117.el7.x86_64
> qemu-kvm-1.5.3-117.el7.x86_64
> qemu-kvm-common-1.5.3-117.el7.x86_64

What is the libvirt version? According to the bug 1283207 it should be fixed in libvirt-2.0.0-1.el7

> 
> client rhel 7.3 nightly
> spice-vdagent-0.14.0-14.el7.x86_64
> spice-protocol-0.12.11-1.el7.noarch
> spice-server-0.12.4-18.el7.x86_64
> xorg-x11-drv-qxl-0.1.1-18.el7.x86_64
Comment 6 Christophe Fergeau 2016-07-18 09:19:31 EDT
Fairly sure QEMU is at fault https://bugzilla.redhat.com/show_bug.cgi?id=1283198#c7
Comment 7 Radek Duda 2016-07-18 09:31:29 EDT
tested on 
libvirt-2.0.0-2.el7.x86_64
ok Christophe I will test it later
Comment 11 Radek Duda 2016-09-02 08:41:42 EDT
I cannot verify this.

tested on client:
qemu-kvm-1.5.3-122.el7.x86_64
spice-server-0.12.4-18.el7.x86_64
libvirt-2.0.0-6.el7.x86_64

set heads='1':
    <video>
      <model type='qxl' ram='262144' vram='262144' vgamem='65536' heads='1' primary='yes'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>

in xml config file of VM guest

I can always open more displays than 1.
Comment 12 Christophe Fergeau 2016-09-02 08:54:17 EDT
Should this really be FailedQE/ASSIGNED? I understand your testing fails, but I have no idea whether what I raised in comment #6 has been solved. Ie I don't think all the pieces are fully in place yet, but it's not necessarily broken on the spice-server side.
Comment 13 Tomas Pelka 2016-09-02 14:43:33 EDT
There are basically two options:

1) as not all pieces are obviously in we are not able fully test. So in theory is should be postponed until all bits are in.

2) we can verify as sanity only and fully test when qemu get fixed

1) is more clean approach from QE POW, on the other hand 2) is more likely from Devel POW. The only concern I have is that if we mark this bz sanity only there is very high possibility we won't test it later.

I would advice to ask in bz1283198 for status and emphasize it is a blocking issue for this bz.
Comment 14 Gerd Hoffmann 2016-09-05 04:48:05 EDT
> Additional info:
> Needs to backport to spice-serve commit
> 6d4e58f70ddf9c178e2cc20dd5a3ade8b95fd142. Better to move to spice-server
> 0.12.6.

Backport isn't going to fly, breaks symbol versioning.
spice-server needs a rebase to 0.12.6 or newer.
Comment 15 David Blechter 2016-09-08 13:28:16 EDT
moving to 7.4, we need 1283198 to be fixed as well
Comment 17 Christophe Fergeau 2017-01-16 12:19:18 EST
Should be part of the rebased spice-0.12.8-1.el7
Comment 21 errata-xmlrpc 2017-08-01 12:06:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1866

Note You need to log in before you can comment on or make changes to this bug.