This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283261 - ceilometer-nova is not configured
ceilometer-nova is not configured
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Kilo
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Shai Revivo
: Automation, Triaged, ZStream
Depends On:
Blocks: 1299563 1302047
  Show dependency treegraph
 
Reported: 2015-11-18 09:29 EST by Daniel Mellado
Modified: 2016-04-20 09:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.10.dev1682.g42b3426.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1299563 (view as bug list)
Environment:
Last Closed: 2016-04-20 09:44:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 253470 None None None Never

  None (edit)
Description Daniel Mellado 2015-11-18 09:29:44 EST
Description of problem:
ceilometer-nova service is not sending notifications due to being unconfigured. Taking http://docs.openstack.org/kilo/install-guide/install/yum/content/ceilometer-nova.html as a model and comparing it to a fresh install shows that the /etc/nova/nova.conf file lacks the notification_driver configuration, among others

Version-Release number of selected component (if applicable):
RHOS7/RHEL7.2

How reproducible:
Run the tempest.api.telemetry.test_telemetry_notification_api.TelemetryNotificationAPITestJSON.test_check_nova_notificationer


Actual results:
Fails due to no notifications being recieved after 300 s

Expected results:

The test to pass

Additional info:
Comment 1 Emilien Macchi 2015-12-02 14:05:55 EST
Could please give more context?
Which installer are you running? Which version?

Thanks
Comment 4 Daniel Mellado 2016-01-18 10:55:27 EST
This issue is also affecting RHOS7. After investigating, it seems that this is a packstack configuration problem.

The configuration from ceilometer is nova.conf over compute nodes should follow the guide's details, i.e.

[DEFAULT]
...
instance_usage_audit = True
instance_usage_audit_period = hour
notify_on_state_change = vm_and_task_state
notification_driver = messagingv2

However, after a default deployment, the following values for them can be found:

[DEFAULT]
notification_driver=ceilometer.compute.nova_notifier
notification_driver=nova.openstack.common.notifier.rpc_notifier
notification_driver=
instance_usage_audit = False
instance_usage_audit_period = month (This value doesn't really affect)
notify_on_state_change = <None>

After changing the values to the ones proposed in the configuration guide [1] and restarting the needed services, the nova notifications start working, and the test now passes.

(.venv)[cloud-user@rhos7_rhel7 tempest-dir]$ python -m testtools.run tempest.api.telemetry.test_telemetry_notification_api.TelemetryNotificationAPITestJSON.test_check_nova_notification
Tests running...

Ran 1 test in 2.140s
OK


---
[1] http://docs.openstack.org/kilo/install-guide/install/yum/content/ceilometer-nova.html
Comment 5 Alan Pevec 2016-02-04 19:31:00 EST
Martin, OpenStack gerrit 253470 was merged, is there anything else left to fix this issue?
Comment 6 Martin Magr 2016-02-05 08:50:32 EST
There is nothing else, I've submitted backports.

Note You need to log in before you can comment on or make changes to this bug.