This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283267 - minidnf should not remove leftover packages when doing a rollback
minidnf should not remove leftover packages when doing a rollback
Status: CLOSED CURRENTRELEASE
Product: otopi
Classification: oVirt
Component: Plugins.packagers (Show other bugs)
1.4.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 1.4.1
Assigned To: Yedidyah Bar David
Karolína Hajná
:
Depends On:
Blocks: 1306019
  Show dependency treegraph
 
Reported: 2015-11-18 09:45 EST by Rafael Martins
Modified: 2016-05-29 08:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 02:40:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48734 master MERGED packagers: minidnf: do not remove leftovers Never

  None (edit)
Description Rafael Martins 2015-11-18 09:45:50 EST
When some otopi consumer asks for a rollback after installing packages using minidnf, it should only remove the packages that were explicitly installed during that transaction.

This is related to the DNF behaviour when removing package requirements. See: http://dnf.readthedocs.org/en/latest/conf_ref.html#clean-requirements-on-remove-label
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-18 10:19:02 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Sandro Bonazzola 2016-02-09 02:01:32 EST
Moving back to modified, 1.4.1 has not been released.
Comment 4 Gil Klein 2016-02-17 02:40:10 EST
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.