Bug 1283273 - Service dialog dropdown list does not auto refresh other fields
Service dialog dropdown list does not auto refresh other fields
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Drew Bomhof
Jeff Teehan
:
Depends On:
Blocks: 1289643 1450397 1450398
  Show dependency treegraph
 
Reported: 2015-11-18 10:10 EST by Bill Wei
Modified: 2017-05-12 08:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289643 1450397 1450398 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:09:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Wei 2015-11-18 10:10:17 EST
Description of problem:
In my particular test I created two dynamic dropdown list in a service dialog. The first is a list of images, and the other is a list of operating systems. When the user selects an image, I want the os dropdown auto selects the corresponding type of the image.

For the image dropdown the "Auto refresh other fields when modified" is checked, and for the os dropdown, the "Auto refresh" is checked.

When the selection of the image list changes, the os list selection does not refresh. The debugging shows the automate method for the os list does not get called. The problem seems the image list does not trigger a refresh.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 eclarizi 2015-12-08 11:16:20 EST
This should be fixed with this PR that went through: https://github.com/ManageIQ/manageiq/pull/5612
Comment 3 eclarizi 2015-12-10 15:54:47 EST
Disregard previous comment. The PR fixed this issue for when the refresh button is pressed, but not for when a new selection is made in the drop-down list.
Comment 5 CFME Bot 2015-12-15 16:35:30 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/305001c6d3c4d717a74155735439021194fb6ebf

commit 305001c6d3c4d717a74155735439021194fb6ebf
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Mon Dec 14 17:31:53 2015 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Tue Dec 15 14:10:23 2015 -0500

    Service dialog dropdown list does not auto refresh other fields
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283273
    
    created a new function to both initialize the select box
    and refresh it when an on change event occurs.

 app/assets/javascripts/dialog_field_refresh.js     | 10 +++++
 .../dialogs/_dialog_field_drop_down_list.html.haml |  4 +-
 spec/javascripts/dialog_field_refresh_spec.js      | 44 ++++++++++++++++++++++
 3 files changed, 55 insertions(+), 3 deletions(-)
Comment 6 CFME Bot 2015-12-16 20:31:46 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6d78e11a030ea91fbc67b74cc9b39ca1b88ebb1c

commit 6d78e11a030ea91fbc67b74cc9b39ca1b88ebb1c
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Mon Dec 14 17:31:53 2015 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Tue Dec 15 17:22:18 2015 -0500

    Service dialog dropdown list does not auto refresh other fields
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283273
    
    created a new function to both initialize the select box
    and refresh it when an on change event occurs.

 app/assets/javascripts/dialog_field_refresh.js     | 10 +++++
 .../dialogs/_dialog_field_drop_down_list.html.haml |  4 +-
 spec/javascripts/dialog_field_refresh_spec.js      | 44 ++++++++++++++++++++++
 3 files changed, 55 insertions(+), 3 deletions(-)
Comment 7 Jeff Teehan 2016-04-20 16:01:14 EDT
I setup a similar set of fields and I can see the refresh is triggering.  Going to move this to verified for 5.6.0.1 using https://10.16.7.174/
Comment 9 errata-xmlrpc 2016-06-29 11:09:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.