Bug 1289643 - Service dialog dropdown list does not auto refresh other fields
Service dialog dropdown list does not auto refresh other fields
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Drew Bomhof
Shveta
: ZStream
Depends On: 1283273 1450397 1450398
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 11:07 EST by John Prause
Modified: 2017-05-12 08:29 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283273
Environment:
Last Closed: 2016-02-10 10:26:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
err (83.73 KB, image/png)
2016-01-19 15:31 EST, Shveta
no flags Details

  None (edit)
Comment 2 CFME Bot 2015-12-16 20:31:55 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=31de83ba354b15a3401f2760333a61d9c3f9be79

commit 31de83ba354b15a3401f2760333a61d9c3f9be79
Merge: 06566ce 6d78e11
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Dec 16 20:27:34 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Dec 16 20:27:34 2015 -0500

    Merge branch '5.5.z_fix_catalog_auto_refresh' into '5.5.z'
    
    Service dialog dropdown list does not auto refresh other fields
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    created a new function to both initialize the select box
    and refresh it when an on change event occurs.
    
    Upstream
    BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1283273
    PR: https://github.com/ManageIQ/manageiq/pull/5843
    
    Cherry-pick was clean
    
    See merge request !626

 app/assets/javascripts/dialog_field_refresh.js     | 10 +++++
 .../dialogs/_dialog_field_drop_down_list.html.haml |  4 +-
 spec/javascripts/dialog_field_refresh_spec.js      | 44 ++++++++++++++++++++++
 3 files changed, 55 insertions(+), 3 deletions(-)
Comment 4 Shveta 2016-01-19 15:31 EST
Created attachment 1116350 [details]
err

Created a catalog item using azure-single-vm-from-user-image dialog for Provider Azure. It has two dynamic drop downs . Selecting values in one drop down refreshes values in another dynamic drop down .

But all the dynamic drop down changes values and shows "Nothing selected " selected. 

Not able to select values hence.
Build 5.5.2.1.20160114044944_395c086 

Can be checked at https://10.16.5.116
Comment 6 Shveta 2016-01-19 16:13:46 EST
Hey Drew, 

That was by mistake. Assigning it to you.

Thanks, 
Shveta
Comment 8 CFME Bot 2016-01-21 09:22:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2f4b46ed4b6b54fa3b44fec8ed02e56c291f8218

commit 2f4b46ed4b6b54fa3b44fec8ed02e56c291f8218
Merge: a1e9578 0557daa
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Jan 21 09:17:32 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Thu Jan 21 09:17:32 2016 -0500

    Merge branch 'resolve_select_picker_issues' into '5.5.z'
    
    Resolve inconsistent dialog auto refresh
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.
    
    See merge request !740

 app/assets/javascripts/dialog_field_refresh.js | 4 +++-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 8 insertions(+), 1 deletion(-)
Comment 9 CFME Bot 2016-01-21 09:22:48 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0557daa87748cd125c46c9dbaf159e91fae534f9

commit 0557daa87748cd125c46c9dbaf159e91fae534f9
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Wed Jan 20 16:44:00 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Wed Jan 20 16:44:00 2016 -0500

    Resolve inconsistent dialog auto refresh
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.

 app/assets/javascripts/dialog_field_refresh.js | 4 +++-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 8 insertions(+), 1 deletion(-)
Comment 11 CFME Bot 2016-01-21 11:31:49 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 13 CFME Bot 2016-01-22 16:30:50 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/93d7c815a256c259db91863b6f646644b65d1428

commit 93d7c815a256c259db91863b6f646644b65d1428
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Wed Jan 20 16:44:00 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Thu Jan 21 10:04:26 2016 -0500

    Resolve inconsistent dialog auto refresh
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.
    Resolves issues found in the following
    two BZ's
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411

 app/assets/javascripts/dialog_field_refresh.js | 2 +-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 14 Shveta 2016-02-02 14:43:42 EST
Fixed.
verified in 

5.5.2.4.20160127105142_395c086
Comment 15 errata-xmlrpc 2016-02-10 10:26:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.