Bug 1283314 - Anaconda install error on SSD (unable to locate a disklabel)
Anaconda install error on SSD (unable to locate a disklabel)
Status: CLOSED DUPLICATE of bug 1259745
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 12:18 EST by goranj
Modified: 2016-02-04 01:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 15:39:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda error to install on SSD (86.87 KB, image/png)
2015-11-18 12:18 EST, goranj
no flags Details
anaconda.log (8.51 KB, text/plain)
2015-11-19 01:18 EST, goranj
no flags Details
ifcfg.log (3.83 KB, text/plain)
2015-11-19 01:19 EST, goranj
no flags Details
program.log (5.87 KB, text/plain)
2015-11-19 01:20 EST, goranj
no flags Details
storage.log (18.92 KB, text/plain)
2015-11-19 01:20 EST, goranj
no flags Details

  None (edit)
Description goranj 2015-11-18 12:18:11 EST
Created attachment 1096181 [details]
Anaconda error to install on SSD

Description of problem: Unable to do a clean install of Fedora23 on Samsung SSD


Version-Release number of selected component (if applicable): Fedora 23


How reproducible: I have Fedora 22 installed on a SSD on a ThinkPad T410, but I wanted to do a clean Fedora23 install. When I started the install I got an error message that says: "For some reason we were unable to locate a disklabel on a disk that the kernel is reporting partitions on. It is unclear what the exact problem is. Please file a bug at http://bugzilla.redhat.com


Steps to Reproduce:
1. Used a Fedora 23 install CD
2. Tried to install on Samsung 120Gb SSD 
3. I formated the disk to ext4 in gparted and I'm still getting the same error.

Harware is Lenovo ThinkPad T410
Comment 1 David Shea 2015-11-18 12:54:51 EST
Please attach the logs from /tmp to this bug as individual, text/plain attachments.
Comment 2 goranj 2015-11-19 01:18 EST
Created attachment 1096491 [details]
anaconda.log
Comment 3 goranj 2015-11-19 01:19 EST
Created attachment 1096492 [details]
ifcfg.log
Comment 4 goranj 2015-11-19 01:20 EST
Created attachment 1096493 [details]
program.log
Comment 5 goranj 2015-11-19 01:20 EST
Created attachment 1096494 [details]
storage.log
Comment 6 goranj 2015-11-19 01:21:40 EST
Logs attached.
Comment 7 David Lehman 2015-11-19 15:39:52 EST

*** This bug has been marked as a duplicate of bug 1259745 ***
Comment 8 goranj 2015-11-19 15:52:13 EST
I don't understand why you marked is as duplicate bug. My disk did not had zfs partitions or anything similar to the other bug. My disk had etx4 partitions and Fedora 22 on it. Plus I used a official release of F23 not beta or an RC release.
Comment 9 David Shea 2015-11-19 16:02:54 EST
Bug 1259745 did not have a zfs filesystem either, but the disk was misidentified as such. So was yours. Note ID_FS_TYPE

01:09:42,867 DEBUG blivet:      Populator.addUdevDevice: name: sda ; info: {'DEVLINKS': '/dev/disk/by-id/ata-Samsung_SSD_840_EVO_120GB_S1D5NSBF251176W '
             '/dev/disk/by-id/wwn-0xd13ea02753885002',
 'DEVNAME': '/dev/sda',
 'DEVPATH': '/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda',
 'DEVTYPE': 'disk',
 'ID_ATA': '1',
 'ID_ATA_DOWNLOAD_MICROCODE': '1',
 'ID_ATA_FEATURE_SET_HPA': '1',
 'ID_ATA_FEATURE_SET_HPA_ENABLED': '1',
 'ID_ATA_FEATURE_SET_PM': '1',
 'ID_ATA_FEATURE_SET_PM_ENABLED': '1',
 'ID_ATA_FEATURE_SET_SECURITY': '1',
 'ID_ATA_FEATURE_SET_SECURITY_ENABLED': '0',
 'ID_ATA_FEATURE_SET_SECURITY_ENHANCED_ERASE_UNIT_MIN': '8',
 'ID_ATA_FEATURE_SET_SECURITY_ERASE_UNIT_MIN': '2',
 'ID_ATA_FEATURE_SET_SECURITY_FROZEN': '1',
 'ID_ATA_FEATURE_SET_SMART': '1',
 'ID_ATA_FEATURE_SET_SMART_ENABLED': '0',
 'ID_ATA_ROTATION_RATE_RPM': '0',
 'ID_ATA_SATA': '1',
 'ID_ATA_SATA_SIGNAL_RATE_GEN1': '1',
 'ID_ATA_SATA_SIGNAL_RATE_GEN2': '1',
 'ID_ATA_WRITE_CACHE': '1',
 'ID_ATA_WRITE_CACHE_ENABLED': '1',
 'ID_BUS': 'ata',
 'ID_FS_TYPE': 'zfs_member',
 'ID_FS_USAGE': 'raid',
 'ID_FS_VERSION': '5000',
 'ID_MODEL': 'Samsung_SSD_840_EVO_120GB',
 'ID_MODEL_ENC': 'Samsung\\x20SSD\\x20840\\x20EVO\\x20120GB\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20\\x20',
 'ID_REVISION': 'EXT0BB6Q',
 'ID_SERIAL': 'Samsung_SSD_840_EVO_120GB_S1D5NSBF251176W',
 'ID_SERIAL_SHORT': 'S1D5NSBF251176W',
 'ID_TYPE': 'disk',
 'ID_WWN': '0xd13ea02753885002',
 'ID_WWN_WITH_EXTENSION': '0xd13ea02753885002',
 'MAJOR': '8',
 'MINOR': '0',
 'MPATH_SBIN_PATH': '/sbin',
 'SUBSYSTEM': 'block',
 'TAGS': ':systemd:',
 'USEC_INITIALIZED': '44000629'} ;
Comment 10 goranj 2015-11-19 16:06:23 EST
Hmmm. Weird. Why is this happening? Fedora 22 was all good. Any workaround for this yet. Thanks.
Comment 11 Gary Funck 2016-02-04 01:03:41 EST
This bug may be related to Bug #1304598.

Note You need to log in before you can comment on or make changes to this bug.