Bug 1304598 - cannot install FC23 with Micron P420m ssd card installed in the system
cannot install FC23 with Micron P420m ssd card installed in the system
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 00:33 EST by nenad
Modified: 2016-12-20 13:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 13:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nenad 2016-02-04 00:33:48 EST
We have FC20 running on a system that has Micron P420m SSD PCIe card installed (does not boot from it).  Tried to upgrade to FC23 but install script fails with a message that it was 'unable to locate disklabel' on 'rssda' drive.

I saw some other reports with the same message but I don't think that our problem is related to any of them.  Our device was visible by the kernel and I was able to mount the only partition we had on it.  

After going through the storage.log install log I noticed that Micron device did not have any links under /dev/disk directories and that pointed to udev manager.  The following line in 

/usr/lib/udev/rules.d/60-persistent-storage.rules 

was the cause of our problem:

 9 KERNEL!="loop*|mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|nvme*|sd*|sr*|vd*|xvd*|bcache*|cciss*|dasd*", GOTO="persistent_storage_end"

As our device is 'rssd*' udev was skipping any kind of work thinking that it is not the storage device.  FC 20 had this logic reversed and that is why it worked for us:

# skip rules for inappropriate block devices
KERNEL=="fd*|mtd*|nbd*|gnbd*|btibm*|dm-*|md*|zram*", GOTO="persistent_storage_end"

At the end I patched the rules file (adding rssd* on line 9) and re-scanned them with 'udevadm trigger'.  Links were created and install process was able to pass the point of checking for suitable devices.
Comment 1 Gary Funck 2016-02-04 01:02:19 EST
This bug may be related to bug #1283314.
Comment 2 Fedora End Of Life 2016-11-24 10:23:05 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2016-12-20 13:25:18 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.