Bug 1283319 - DNF builddep fails
DNF builddep fails
Status: CLOSED DUPLICATE of bug 1272936
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 12:28 EST by Sean V Kelley
Modified: 2015-11-19 06:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:19:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean V Kelley 2015-11-18 12:28:13 EST
Description of problem:

Unable to execute dnf builddep on a clean install of Fedora 23

Version-Release number of selected component (if applicable): 

[seanvk@ashland-svkelley ~]$ dnf --version
1.1.3
  Installed: dnf-0:1.1.3-1.fc23.noarch at 2015-10-29 21:23
  Built    : Fedora Project at 2015-10-14 16:54

  Installed: rpm-0:4.13.0-0.rc1.6.fc23.x86_64 at 2015-11-18 01:34
  Built    : Fedora Project at 2015-11-09 08:44


How reproducible:

Every time (100%)

Steps to Reproduce:
1. Install Fedora 23 Workstation edition
2. Execute:  sudo dnf builddep libva
3. Look at output

Actual results:

[seanvk@ashland-svkelley ~]$ sudo dnf builddep libva
[sudo] password for seanvk: 
enabling updates-source repository
enabling fedora-source repository
Fedora 23 - Updates Source                       43 kB/s | 662 kB     00:15    
Fedora 23 - Source                              331 kB/s | 5.9 MB     00:18    
Last metadata expiration check performed 0:00:00 ago on Wed Nov 18 09:06:58 2015.
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python3.4/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'


Expected results:

DNF installs the build dependencies

Additional info:
Comment 1 Sean V Kelley 2015-11-18 12:39:00 EST
But running:

sudo dnf builddep mesa-dri-drivers

works.

So is this a packaging issue instead?  But the error is cryptic to me and I'm looking for guidance.

Thanks,

Sean
Comment 2 Daniel 2015-11-18 14:25:21 EST
Same problem, with rpm fusion installed on F22

sudo dnf builddep libva
enabling fedora-source repository
enabling rpmfusion-free-updates-source repository
enabling rpmfusion-nonfree-updates-source repository
enabling rpmfusion-free-source repository
enabling updates-source repository
enabling rpmfusion-nonfree-source repository
Fedora 22 - Updates Source                                                                                                                                                                                                                                                                                                 1.3 MB/s | 2.1 MB     00:01    
RPM Fusion for Fedora 22 - Nonfree - Updates Source                                                                                                                                                                                                                                                                         22 kB/s | 7.6 kB     00:00    
RPM Fusion for Fedora 22 - Nonfree - Source                                                                                                                                                                                                                                                                                171 kB/s |  35 kB     00:00    
RPM Fusion for Fedora 22 - Free - Updates Source                                                                                                                                                                                                                                                                            87 kB/s |  15 kB     00:00    
Fedora 22 - Source                                                                                                                                                                                                                                                                                                         1.5 MB/s | 5.8 MB     00:03    
RPM Fusion for Fedora 22 - Free - Source                                                                                                                                                                                                                                                                                   247 kB/s |  83 kB     00:00    
Last metadata expiration check performed 0:00:00 ago on Wed Nov 18 11:18:19 2015.
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python2.7/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python2.7/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'
Comment 3 Michael Mráka 2015-11-19 06:19:19 EST
It's been fixed in bug #1272936 and updated packages are in updates-testing now.

*** This bug has been marked as a duplicate of bug 1272936 ***

Note You need to log in before you can comment on or make changes to this bug.