Bug 128337 - PS2 mouse fails after upgrade when using 2.4 kernel
PS2 mouse fails after upgrade when using 2.4 kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 16:57 EDT by Hans de Goede
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 17:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modfied gpm start script to work with both 2.6 and 2.4 (1.89 KB, text/plain)
2004-07-21 17:12 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2004-07-21 16:57:07 EDT
When booting a 2.4 kernel after an upgrade to FC2 or FC3-test, the
mouse doesn't function, because of the usage of /dev/input/mice for
2.6 kernels instead of /dev/psaux and IMPS/2 instead of the real mouse
protocol.

X
=================================================================

For X this can be fixed by making /dev/input/mice, IMPS/2 the
CorePointer, and the original mouse config AlwaysCore

The current upgrade-path replaces the CorePointer config by
/dev/input/mice, IMPS/2. Resulting in a config with both the
COrePointer and the AlwaysCore extra mouse pointing to
/dev/input/mice, since /dev/input/mice as AlwaysCore already was
present for USB support.

If you change the original mouse to AlwaysCore and the AlwaysCore
config there for USB to CorePointer, then X works fine under both 2.4
and 2.6.

gpm
=====================================================================

GPM is rather harder to fix, this because the upgrade changes
/etc/sysconfig/mouse. My suggestion don't touch /etc/sysconfig/mouse,
this should contain info about the real mouse, not the way the kernel
reports it.

Next modifiy /etc/rc.d/init.d/gpm to check what kernel is running:
-2.4 just use the info in /etc/sysconfig/mouse
-2.6 if its a PS/2 mouse use /dev/input/mice, IMPS/2, other wise
continue as usual.
Comment 1 Hans de Goede 2004-07-21 17:10:05 EDT
I just saw in another bug that 2.4 support is going to be dropped
completly from FC3, so I'm closing this.
Comment 2 Hans de Goede 2004-07-21 17:12:02 EDT
Created attachment 102118 [details]
modfied gpm start script to work with both 2.6 and 2.4

I'm attaching a modified gpm startscript for people still wanting to use 2.4
mixed wirh 2.6, note you should also manually downgrade to the FC2 modutils!
Comment 3 Mike MacCana 2004-07-22 04:27:01 EDT
*** Bug 128366 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.