Bug 12834 - oracle_setup.pl leaves out contract field from groups table
Summary: oracle_setup.pl leaves out contract field from groups table
Status: CLOSED DEFERRED
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.8
Hardware: i386
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 12835 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-22 23:59 UTC by amoore
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 23:59:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description amoore 2000-06-22 23:59:07 UTC
The definition of the groups table in the oracle_setup.pl setup script
leaves out a column. It fails to create the "contract" field. near line 643
in the table definition for "groups" a line like:

contract    INTEGER      DEFAULT(0)";

needs to be inserted.

(this field is used by the AddGroup in the same script for example)

Comment 1 David Lawrence 2000-06-23 14:33:54 UTC
Thank you for bringing this to my attention. The oracle_setup.pl file is a
serious need of updating. I did the conversion of check_setup.pl (for Mysql) a
while back and then had to make a lot of changes to the database structure that
I have not had a chance to add them into the oracle_setup.pl script as of yet. I
will hopefully be finishing this up real soon now. Until then I recommend people
with database experience to use the .sql scripts located in the oracle sub
directory until then.


Comment 2 David Lawrence 2000-06-23 14:55:35 UTC
*** Bug 12835 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.