Bug 1283424 - Incorrect Automate Message in 2 Profile Classes
Incorrect Automate Message in 2 Profile Classes
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity low
: GA
: 5.6.0
Assigned To: mkanoor
luke couzens
:
Depends On:
Blocks: 1288154
  Show dependency treegraph
 
Reported: 2015-11-18 17:59 EST by mkanoor
Modified: 2016-06-29 11:09 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288154 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:09:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkanoor 2015-11-18 17:59:59 EST
Description of problem:
Incorrect Automate Message in 2 Profile Classes

Version-Release number of selected component (if applicable):
5.5.5

How reproducible:
100%

Steps to Reproduce:
1. Start Automate Explorer
2. Check the Message for the Automate Method Field get_dialog_name in the following classes
3. /ManageIQ/Cloud/VM/Provisioning/Profile
   /ManageIQ/Infrastructure/VM/Provisioning/Profile

Actual results:
Message is incorrectly set to get_state_machine

Expected results:
Message should be get_dialog_name

Additional info:
Comment 3 CFME Bot 2015-11-19 14:00:22 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/99fe78b2147ce57a1a54d18de9f285afe5fa5e11

commit 99fe78b2147ce57a1a54d18de9f285afe5fa5e11
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Nov 19 11:52:17 2015 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Thu Nov 19 11:52:17 2015 -0500

    Fixed Automate Message in 2 classes
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283424
    
    Incorrect message 'get_state_machine' should be 'get_dialog_name'

 .../ManageIQ/Cloud/VM/Provisioning/Profile.class/__class__.yaml         | 2 +-
 .../Infrastructure/VM/Provisioning/Profile.class/__class__.yaml         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 4 CFME Bot 2015-12-07 13:51:14 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ebf10bcd55f123b9ac62d81779beff306e6a53a7

commit ebf10bcd55f123b9ac62d81779beff306e6a53a7
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Thu Nov 19 11:52:17 2015 -0500
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Thu Dec 3 12:08:10 2015 -0500

    Fixed Automate Message in 2 classes
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283424
    
    Incorrect message 'get_state_machine' should be 'get_dialog_name'

 .../ManageIQ/Cloud/VM/Provisioning/Profile.class/__class__.yaml         | 2 +-
 .../Infrastructure/VM/Provisioning/Profile.class/__class__.yaml         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 5 luke couzens 2016-04-18 08:26:27 EDT
Verified in 5.6.0.1-beta2
Comment 7 errata-xmlrpc 2016-06-29 11:09:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.