Bug 1283425 - [RFE] Service summary page should show VMs provisioned through orchestration service
Summary: [RFE] Service summary page should show VMs provisioned through orchestration ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Bill Wei
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard: service:provision:stack
Depends On:
Blocks: 1287895
TreeView+ depends on / blocked
 
Reported: 2015-11-18 23:00 UTC by Bill Wei
Modified: 2016-06-29 15:09 UTC (History)
2 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1287895 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:09:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Bill Wei 2015-11-18 23:00:32 UTC
Description of problem:
Currently the summary page always shows no VMs resulted from the provisioning. 

Version-Release number of selected component (if applicable):


How reproducible:

Prepare an orchestration template that creates one or more virtual machines. Create a catalog item with type orchestration based on this template. Order the service. Should verify the service summary page showing the correct VMs generated. 


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 CFME Bot 2015-11-25 21:50:17 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/eb451b32eacb4de814822ada2ad97586ef261f7d

commit eb451b32eacb4de814822ada2ad97586ef261f7d
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Thu Nov 19 10:13:02 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Wed Nov 25 14:37:23 2015 -0500

    Refactor OrchstarationStack to return all VMs
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283425
    
    1. OrchestratiosStack has methods to return all VMs or direct VMs
    2. ServiceOrchestration delegates OrchestrationStack#all_vms and direct_vms

 app/models/orchestration_stack.rb                | 31 +++++++++++++++++--
 app/models/service_orchestration.rb              | 12 ++++++++
 spec/models/miq_expression/model_details_spec.rb |  2 +-
 spec/models/orchestration_stack_spec.rb          | 38 ++++++++++++++++++++++++
 spec/models/service_orchestration_spec.rb        | 23 +++++++++++++-
 5 files changed, 101 insertions(+), 5 deletions(-)
 create mode 100644 spec/models/orchestration_stack_spec.rb

Comment 4 CFME Bot 2015-12-07 19:33:41 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8df24d47ca6a78209441e2120346b40a6f812edf

commit 8df24d47ca6a78209441e2120346b40a6f812edf
Author:     Bill Wei <bilwei@redhat.com>
AuthorDate: Thu Nov 19 10:13:02 2015 -0500
Commit:     Bill Wei <bilwei@redhat.com>
CommitDate: Mon Nov 30 09:34:53 2015 -0500

    Refactor OrchstarationStack to return all VMs
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283425
    
    1. OrchestratiosStack has methods to return all VMs or direct VMs
    2. ServiceOrchestration delegates OrchestrationStack#all_vms and direct_vms

 app/models/orchestration_stack.rb                | 31 +++++++++++++++++--
 app/models/service_orchestration.rb              | 12 ++++++++
 spec/models/miq_expression/model_details_spec.rb |  2 +-
 spec/models/orchestration_stack_spec.rb          | 38 ++++++++++++++++++++++++
 spec/models/service_orchestration_spec.rb        | 23 +++++++++++++-
 5 files changed, 101 insertions(+), 5 deletions(-)
 create mode 100644 spec/models/orchestration_stack_spec.rb

Comment 5 Niyaz Akhtar Ansari 2016-04-19 11:57:38 UTC
Service summary page is show VMs provision through orchestration service
verified in 5.6.0.1-beta2.20160413141124_e25ac0e

Comment 7 errata-xmlrpc 2016-06-29 15:09:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.