Bug 1287895 - [RFE] Service summary page should show VMs provisioned through orchestration service
[RFE] Service summary page should show VMs provisioned through orchestration ...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Bill Wei
Jeff Teehan
: FutureFeature, ZStream
Depends On: 1283425
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 18:18 EST by Bill Wei
Modified: 2016-02-10 10:21 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1283425
Environment:
Last Closed: 2016-02-10 10:21:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-12-07 14:33:46 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2f5252e66362e5333e1b35e36c9347e14c85b37e

commit 2f5252e66362e5333e1b35e36c9347e14c85b37e
Merge: 49e7436 8df24d4
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Dec 7 14:29:29 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Dec 7 14:29:29 2015 -0500

    Merge branch '5.5.z_service_summary' into '5.5.z'
    
    Refactor OrchstarationStack to return all VMs
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287895
    
    1. OrchestratiosStack has methods to return all VMs or direct VMs
    2. ServiceOrchestration delegates OrchestrationStack#all_vms and direct_vms
    
    Original PR: https://github.com/ManageIQ/manageiq/pull/5577
    
    See merge request !545

 app/models/orchestration_stack.rb                | 31 +++++++++++++++++--
 app/models/service_orchestration.rb              | 12 ++++++++
 spec/models/miq_expression/model_details_spec.rb |  2 +-
 spec/models/orchestration_stack_spec.rb          | 38 ++++++++++++++++++++++++
 spec/models/service_orchestration_spec.rb        | 23 +++++++++++++-
 5 files changed, 101 insertions(+), 5 deletions(-)
Comment 4 Jeff Teehan 2016-01-20 16:44:33 EST
Created the items as described above using the Azure template.  The description page contained all the correct information.  Moving to Verified.

Used 5.5.2.1 on https://10.16.6.21/miq_request/show/114r1
Comment 5 errata-xmlrpc 2016-02-10 10:21:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.