Bug 128344 - vimrc contains incorrect control sequences for xterm
vimrc contains incorrect control sequences for xterm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 18:50 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 05:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2004-07-21 18:50:23 EDT
The /etc/vimrc (6.3.013-2) appears to have a bug.  This section:
     if &term=="xterm"
          set t_Co=8
          set t_Sb=^[4%dm
          set t_Sf=^[3%dm
     endif
is wrong -- t_Sb and t_Sf begin with a literal circumflex followed by
a left square bracket, when the xterm control sequence for selecting
the color should instead begin with a literal escape followed by a
left square bracket.  Replacing the two circumflexes with an escape
character seems to fix it on my system.

This could be the cause of bug #115499.
Comment 1 Karsten Hopp 2004-07-22 05:11:52 EDT
Not sure if cvs mangled the file or if I made a cut&paste error, 
 but it should be fixed now. 

Note You need to log in before you can comment on or make changes to this bug.