Bug 1283448 - python3-dnf-plugins-core update fails with file conflicts
python3-dnf-plugins-core update fails with file conflicts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
: 1285233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 19:19 EST by Michal Jaegermann
Modified: 2016-01-07 07:54 EST (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.15-1.fc23 dnf-plugins-core-0.1.15-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 16:59:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2015-11-18 19:19:58 EST
Description of problem:

An attempt to run an update transaction which includes python3-dnf-plugins-core fails with the following message:

Transaction check error:
  file /usr/share/locale/ca/LC_MESSAGES/dnf-plugins-core.mo from install of python3-dnf-plugins-core-0.1.14-1.fc24.noarch conflicts with file from package python-dnf-plugins-core-0.1.13-1.fc24.noarch
  file /usr/share/locale/da/LC_MESSAGES/dnf-plugins-core.mo from install of python3-dnf-plugins-core-0.1.14-1.fc24.noarch conflicts with file from package python-dnf-plugins-core-0.1.13-1.fc24.noarch



Version-Release number of selected component (if applicable):
python3-dnf-plugins-core-0.1.14-1.fc24

How reproducible:
always on an attempt to update

Additional info:
To get around I had to 'rpm -U --nodeps --replacefiles python3-dnf-plugins-core-0.1.14-1.fc24.noarch.rpm'.  After forcing this the rest of the original update transaction runs.
Comment 1 Honza Silhan 2015-11-20 09:39:14 EST
Thanks for the report. Was it "everything" update (dnf upgrade) or "explicit" upgrade (dnf upgrade ... dnf-plugins-core). The symptoms seems similar to [1] comment.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1231572#c6
Comment 2 Michal Jaegermann 2015-11-20 11:31:34 EST
(In reply to Jan Silhan from comment #1)
> Thanks for the report. Was it "everything" update (dnf upgrade) or
> "explicit" upgrade (dnf upgrade ... dnf-plugins-core).

As a matter of fact both.  Why this is relevant?

> The symptoms seems similar to [1] comment.
> 
> [1] https://bugzilla.redhat.com/show_bug.cgi?id=1231572#c6

Yes, indeed (but a bugzilla search failed to match this one even if this is really the same bug).  It looked from the beginning like an "obvious" packaging error; this time for rawhide.
Comment 3 Honza Silhan 2015-11-23 07:52:13 EST
(In reply to Michal Jaegermann from comment #2)
> (In reply to Jan Silhan from comment #1)
> > Thanks for the report. Was it "everything" update (dnf upgrade) or
> > "explicit" upgrade (dnf upgrade ... dnf-plugins-core).
> 
> As a matter of fact both.  Why this is relevant?

dnf upgrade should update them fine while "dnf upgrade dnf-plugins-core" prints error (wrong packaging of plugins)

PR: https://github.com/rpm-software-management/dnf-plugins-core/pull/135
Comment 4 Fedora Update System 2015-12-18 12:46:27 EST
dnf-plugins-core-0.1.15-1.fc23 dnf-1.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 5 Fedora Update System 2015-12-18 12:48:20 EST
dnf-plugins-core-0.1.15-1.fc22 dnf-1.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 6 Fedora Update System 2015-12-19 14:59:15 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 7 Fedora Update System 2015-12-22 10:34:58 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 8 Fedora Update System 2015-12-22 16:58:32 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-01-04 14:51:49 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Honza Silhan 2016-01-07 07:54:22 EST
*** Bug 1285233 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.