Bug 128358 - X crashes - [drm:i830_wait_ring] *ERROR* space: ... wanted 131064
X crashes - [drm:i830_wait_ring] *ERROR* space: ... wanted 131064
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 128862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-21 22:55 EDT by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 09:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
x session file before starting x - copied (65.94 KB, text/plain)
2004-07-22 08:45 EDT, Jim Cornette
no flags Details
this is the latest log messages - checked in runlevel 1 (110.40 KB, text/plain)
2004-07-22 08:47 EDT, Jim Cornette
no flags Details
before X started up -after shutdown (3.22 KB, text/plain)
2004-07-22 08:48 EDT, Jim Cornette
no flags Details
ps -A - what's up in procceses (1.93 KB, text/plain)
2004-07-23 09:28 EDT, Jim Cornette
no flags Details
With blocked up screen. This is dmesg saved to floppy (15.08 KB, text/plain)
2004-07-23 09:37 EDT, Jim Cornette
no flags Details
process running before computer crashe (3.15 KB, text/plain)
2004-07-27 11:44 EDT, Jim Cornette
no flags Details
This is what is left running processes (2.28 KB, text/plain)
2004-07-27 11:46 EDT, Jim Cornette
no flags Details
using diff from the two resulting files (1023 bytes, text/plain)
2004-07-27 11:48 EDT, Jim Cornette
no flags Details
mtrr state before crash (203 bytes, text/plain)
2004-07-29 14:29 EDT, Jim Cornette
no flags Details
/proc/mtrr after crash (203 bytes, text/plain)
2004-07-29 14:30 EDT, Jim Cornette
no flags Details
this is the difference between the mtrr process value (154 bytes, text/plain)
2004-07-29 14:32 EDT, Jim Cornette
no flags Details
these are processes running or deleted for repeatability ps -A (1.09 KB, text/plain)
2004-07-29 14:34 EDT, Jim Cornette
no flags Details
Versions of xorg-x11 from CVS installed (415 bytes, text/plain)
2004-08-16 15:46 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2004-07-21 22:55:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I am not on this machine now. (Home) I could not give versions
exactly. This system was fully updated before the crash from the ncsu
mirror. Crash was on 7/21/04


The general specs are the crash occured with the smp kernel and after
about an hour ad a half after running. Screensavers were set to cycle
every minute.
Better description later from email to test list.

Version-Release number of selected component (if applicable):
kernel-2.6*464smp

How reproducible:
Didn't try

Steps to Reproduce:
1. run the smp kernel
2. login using runlevel 3
3. transfer 9 gigs of info via ftp to machine
4. notice screen locked up, other processes still functioning
5. try to ctl-alt-Fx to other terminals
    

Actual Results:  no response from keyboard entries. No screen changes
on display.

Expected Results:  machine should have been cycling screensavers and a
keypress or mouse movement should have displayed the programs running
in the GUI.

Additional info:


On the dell computer that I got the video to work by advice by people
on the list. I had X displaying a black screen w/ white dots scattered
sparsely. I also could not switch to any screen terminal and the
keyboard lights were out.
I was running the ftp client to transfer files from a windows computer
to the FC3T1 fresh install. This service was still transferring files
and also the web server was still working.
I eventually had the file transfer complete,then pressed ctl-alt-del
and the computer eventually rebooted. I did not see any difference on
the screen until I saw the grub menu. Then the computer booted up into
windows. This indicates that the system should have entered runlevel 6
after the ctl-alt-del.

A basic summary regarding the conditions the system was booted in follow:
- Running the latest 494smp kernel
- On bootup, a message regarding AGP and S3 conflicting disabling S3
- Some odd boot messages passing quickly by, no apparent errors displayed.
- Screen savers set to cycle every minute randomly. Was logged into X
as a regular user.
Checked computer periodically and all seemed alright. After about 1.5
hrs, noticed screen displaying the speckled white dots and smears.
Noted ftp transfer still proceeding. Also checked apache was functioning.
processor is a P4 w/ hyperthreading, 512 MB memory.

My questions are regarding what logs to provide?
What config files to provide?
What runlevel to boot into. (I use level 3 mostly, would level 1 be
better?)
Any other additions of useful testing practices appreciated. I don't
want to wipe any info out that might aid in bug resolution.

I added high priority because of keyboard non responsive and most
people would consider machine crashed.
Comment 1 Jim Cornette 2004-07-22 08:43:24 EDT
I booted up the computer in runlevel 1. i then checked and copied logs
for messages, boot, x-session errors before telinit to runlevel 3 to
submit report.
Linux amrc-server 2.6.7-1.494smp #1 SMP Sat Jul 17 05:34:46 EDT 2004
i686 i686 i386 GNU/Linux
The rest is just attached logs.
Comment 2 Jim Cornette 2004-07-22 08:45:06 EDT
Created attachment 102140 [details]
x session file before starting x - copied

this does indicate errors reported. I hope something is decent there with the
output
Comment 3 Jim Cornette 2004-07-22 08:47:01 EDT
Created attachment 102142 [details]
this is the latest log messages - checked in runlevel 1

This log shows that the system shut down and also the next attachmeng of
xorg.log.0 will show points of lockup
Comment 4 Jim Cornette 2004-07-22 08:48:48 EDT
Created attachment 102143 [details]
before X started up -after shutdown

There are several errors regarding system lockup. I think this will help.
abandoning ship now!
Comment 5 Jim Cornette 2004-07-22 09:17:12 EDT
Reviewing the log, I noticed that the process started to use the 8 meg
of vesa memory from bios. It reported 8 meg of stolen memory later. It
looks to me like it eventually used the agp, which is set to 128 MB.
The bios version that the computer booted up using is version A04.
The computer model is a Dell Optiplex - GX270 series. The processor is
a Pentium 4 - 2.6 GHz.
When I was uning the original BIOS that was on the computer. (bought
with). The computer had BIOS version A03 and could only go into 640 x
480 video mode. The computer did not eventually switch to AGP or use
the vesa 8 meg legacy from BIOS.
Comment 6 Jim Cornette 2004-07-22 12:24:28 EDT
As information that the X server locks up and that the screensaver is
independent. I tried this out for lockup again. Knowing that the X
server was locked and the computer keyboard was usable. I blindly
proceeded to ctl-alt-F5, then login. I repeated the steps for other
mingetty consoles. Finally, I went to my root login and issued reboot
in the terminal and pressed enter. The machine rebooted and the screen
stayed the same with the screensaver that was active at the time. This
was a screensaver that swirled a bluiesh color.
Since the machine is not locked up and X just seems to be falling out.
I was wondering if telinit to a different runlevel, after the X crash
would reveal anything useful?
There are some updates from development that I did not apply yet. They
were basically libraries and a few misc. gcc++ and whatever the ncsu
mirror has on 7/22/2004. Usually a day behind. 
Comment 7 Jim Cornette 2004-07-23 09:28:35 EDT
Created attachment 102174 [details]
ps -A - what's up in procceses

This seems to be DOS formatted. It looks like runn on lines. I hope this is
useful.
Comment 8 Jim Cornette 2004-07-23 09:37:05 EDT
Created attachment 102175 [details]
With blocked up screen. This is dmesg saved to floppy

I guess this will allow you to determine differences in the previous logs
submitted> Is this locking up the video hardware? can it be refreshed/reset
when errors encountered? ctl-alt-backspace does not change screen output. I did
not test if ctl-alt-backspace would defaulted me to the terminal startx was
initialized in. I assume the login terminal would have been reached.
Comment 9 Jim Cornette 2004-07-27 11:44:52 EDT
Created attachment 102224 [details]
process running before computer crashe

output sent to file
Comment 10 Jim Cornette 2004-07-27 11:46:22 EDT
Created attachment 102225 [details]
This is what is left running processes

Notice X is not there any longer. See next attachment for difference file
Comment 11 Jim Cornette 2004-07-27 11:48:33 EDT
Created attachment 102226 [details]
using diff from the two resulting files

This is what was not running after the crash of X. I ran poweroff from the ssh
console on the RHL8 computer to shut off the computer.
Comment 12 Jim Cornette 2004-07-29 14:29:33 EDT
Created attachment 102294 [details]
mtrr state before crash
Comment 13 Jim Cornette 2004-07-29 14:30:36 EDT
Created attachment 102295 [details]
/proc/mtrr after crash
Comment 14 Jim Cornette 2004-07-29 14:32:14 EDT
Created attachment 102296 [details]
this is the difference between the mtrr process value
Comment 15 Jim Cornette 2004-07-29 14:34:52 EDT
Created attachment 102297 [details]
these are processes running or deleted for repeatability ps -A

I believe that tty2 gets wiped out and so does the X related processes. tty 2
is where X was launched.
Comment 16 Jim Cornette 2004-07-29 14:36:18 EDT
Correction: tty3 on this test. tty2 was on the last trial! END
Comment 17 Jim Cornette 2004-07-30 13:31:48 EDT
Trying every screensaver through the preview mode. Other than a few
errors with yellow text that did not crash X, I found the following
screensavers to crash X.

noof (repeatable, tried twice)
StarWars (Repeatable, tried three times)

Another screensaver just gives a white screen. The screensaver is
GLEidescope.
Comment 18 Jim Cornette 2004-07-30 13:51:02 EDT
opened bug 128862 against StarWars and noof
Comment 19 Ray Strode [halfline] 2004-07-30 13:57:24 EDT
*** Bug 128862 has been marked as a duplicate of this bug. ***
Comment 20 Jim Cornette 2004-07-30 22:17:10 EDT
I made an observation in the two diff files that I tracked with before
and after X crashed. In comment 11 there is rd-bomb designated as
still around after the crash. I got lost with all the > and <
designations but then spotted a similarity in comment 15 diff file.
The screensaver does running when the crash happened is still in the
running processes.

Also, I noticed that GLBlur did not crash immediately when trying to
preview it. However, it crashed shortly after it started running.

Thanks,

Jim
Comment 21 Jim Cornette 2004-08-11 11:34:27 EDT
I tried running StarWars after upgrading both xscreensavers and
xorg-x11 and booting with the latest kernel.

The results were the same for crashing X w/ certain selected screensavers.

I read the changelog for both xorg-x11 and for xscreensaver and did
not see any applicable changes which would change the outcome of this bug.
I noted some i810 changes listed, but none concerning memory
corruption between the 1810 driver or cleaning up the limits for
marked screensavers included.

It seems to me that this problem seems to effect lower resolution
graphics. glxgears seems to spew out high values.
Comment 22 Jim Cornette 2004-08-16 15:46:24 EDT
Created attachment 102773 [details]
Versions of xorg-x11 from CVS installed 

After installing the versions of xorg-x11 listed in attachment, the
screensavers StarWars and noof did not cause the X server to crash during
preview testing. The latest versions for xscreensaver was also installed before
testing the screensavers. I figure X improvements reduced the crashing, since
cosmetic changes were listed in the changelog.
The improvements are great for the 845 card but did not work for another 815
card that used the same i810 driver.
A bug report for the other card was submitted to xorg bugzilla. Thanks for this
fix, intentional or accidental. :-)
Jim
Comment 23 Jim Cornette 2004-08-19 09:03:11 EDT
After a longer duration test with many screensavers selected and
cycling, I determined that the stability of this particular version of
X resolved the random disappearance of X.
After reading posts on several mailing lists, It seems that the 830
card  has problems logging out successfully with certain versions of
X. I know that the newer version does not work properly with the 815 card.

Anyway, the driver should be divided into three or whatever amount of
driver versions needed, for customizing the reliability and
performance characteristics for each card. This particular customizing
of the driver works for maybe the 845 video card versions. Prior
versions seem to work great for the 815 cards without killing X or
having any instability issues.

This bug is closed.

Note You need to log in before you can comment on or make changes to this bug.