Bug 1283589 - Clicking on <None> template in service catalog ends up on Services / Requests page
Clicking on <None> template in service catalog ends up on Services / Requests...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Kyrylo Zvyagintsev
service:catalog
:
Depends On:
Blocks: 1296947
  Show dependency treegraph
 
Reported: 2015-11-19 06:16 EST by Pete Savage
Modified: 2016-06-29 11:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296947 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:10:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-11-19 06:16:50 EST
Description of problem: Clicking on <None> template in service catalog ends up on Services / Requests page


Version-Release number of selected component (if applicable): 5.5.0.11


How reproducible: 100%


Steps to Reproduce:
1. Services -> Catalogs -> Catalog Items -> Add new Catalog Item
2. Choose VMware
3. Click Request Info Tab
4. Under the template "Select" click on the <None> table entry

Actual results:
You end up on the Services Requests page with a flash message stating:
Edit aborted! CFME does not support the browser's back button or access from multiple tabs or windows of the same browser. Please close any duplicate sessions before proceeding.

Expected results: Nothing


Additional info:
----] I, [2015-11-19T06:13:29.559927 #2959:69f988]  INFO -- : Started POST "/miq_request/prov_field_changed/?service__src_vm_id=__VM__NONE__&id=" for 127.0.0.1 at 2015-11-19 06:13:29 -0500
[----] I, [2015-11-19T06:13:29.563731 #2959:69f988]  INFO -- : Processing by MiqRequestController#prov_field_changed as JS
[----] I, [2015-11-19T06:13:29.563973 #2959:69f988]  INFO -- :   Parameters: {"service__src_vm_id"=>"__VM__NONE__", "id"=>""}
[----] I, [2015-11-19T06:13:29.705483 #2959:69f988]  INFO -- : Completed 200 OK in 141ms (Views: 2.2ms | ActiveRecord: 5.2ms)
[----] I, [2015-11-19T06:13:29.929155 #2959:69f988]  INFO -- : Started GET "/miq_request/show_list?escape=false&load_edit_err=true" for 127.0.0.1 at 2015-11-19 06:13:29 -0500
[----] I, [2015-11-19T06:13:29.931837 #2959:69f988]  INFO -- : Processing by MiqRequestController#show_list as HTML
[----] I, [2015-11-19T06:13:29.932021 #2959:69f988]  INFO -- :   Parameters: {"escape"=>"false", "load_edit_err"=>"true"}
[----] I, [2015-11-19T06:13:30.086166 #2959:69f988]  INFO -- :   Rendered layouts/_flash_msg.html.haml (0.2ms)
[----] I, [2015-11-19T06:13:30.090186 #2959:69f988]  INFO -- :   Rendered miq_request/_prov_options.html.haml (4.4ms)
[----] I, [2015-11-19T06:13:30.090840 #2959:69f988]  INFO -- :   Rendered layouts/_info_msg.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.093972 #2959:69f988]  INFO -- :   Rendered layouts/_list_grid.html.haml (2.3ms)
[----] I, [2015-11-19T06:13:30.094158 #2959:69f988]  INFO -- :   Rendered layouts/gtl/_list.html.haml (3.1ms)
[----] I, [2015-11-19T06:13:30.094261 #2959:69f988]  INFO -- :   Rendered layouts/_gtl.html.haml (3.7ms)
[----] I, [2015-11-19T06:13:30.094382 #2959:69f988]  INFO -- :   Rendered miq_request/show_list.html.haml within layouts/application (8.8ms)
[----] I, [2015-11-19T06:13:30.094671 #2959:69f988]  INFO -- :   Rendered layouts/_doctype.html.haml (0.0ms)
[----] I, [2015-11-19T06:13:30.100370 #2959:69f988]  INFO -- :   Rendered stylesheets/_template50.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.107012 #2959:69f988]  INFO -- :   Rendered layouts/_user_options.html.haml (5.2ms)
[----] I, [2015-11-19T06:13:30.206855 #2959:69f988]  INFO -- :   Rendered layouts/_page_header_navbar.html.haml (99.5ms)
[----] I, [2015-11-19T06:13:30.207324 #2959:69f988]  INFO -- :   Rendered layouts/_spinner.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.207601 #2959:69f988]  INFO -- :   Rendered layouts/_lightbox_panel.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.207712 #2959:69f988]  INFO -- :   Rendered layouts/_header.html.haml (106.2ms)
[----] I, [2015-11-19T06:13:30.208503 #2959:69f988]  INFO -- :   Rendered layouts/_center_buttons.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.208734 #2959:69f988]  INFO -- :   Rendered layouts/_x_custom_buttons.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.209015 #2959:69f988]  INFO -- :   Rendered layouts/_view_buttons.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.210102 #2959:69f988]  INFO -- :   Rendered layouts/_taskbar.html.haml (1.9ms)
[----] I, [2015-11-19T06:13:30.210451 #2959:69f988]  INFO -- :   Rendered layouts/_breadcrumbs.html.haml (0.0ms)
[----] I, [2015-11-19T06:13:30.210716 #2959:69f988]  INFO -- :   Rendered layouts/_tabs.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.210942 #2959:69f988]  INFO -- :   Rendered layouts/_content.html.haml (3.0ms)
[----] I, [2015-11-19T06:13:30.211370 #2959:69f988]  INFO -- :   Rendered layouts/_adv_search.html.haml (0.1ms)
[----] I, [2015-11-19T06:13:30.211506 #2959:69f988]  INFO -- :   Rendered layouts/_footer.html.haml (0.4ms)
[----] I, [2015-11-19T06:13:30.223797 #2959:69f988]  INFO -- : Completed 200 OK in 292ms (Views: 108.7ms | ActiveRecord: 26.8ms)
Comment 2 CFME Bot 2016-01-07 18:11:04 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/751ff20f1bf49e2dbba6d0a4e8b7a93465dff59c

commit 751ff20f1bf49e2dbba6d0a4e8b7a93465dff59c
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 17:03:37 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 17:03:37 2016 -0500

    Fixed a typo in variable name in the link.
    
    - Added spec test to verify correct link is being built for rows in the grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283589

 app/views/miq_request/_prov_vm_grid.html.haml      |  2 +-
 .../miq_request/_prov_vm_grid.html.erb_spec.rb     | 27 ++++++++++++++++++++++
 2 files changed, 28 insertions(+), 1 deletion(-)
 create mode 100644 spec/views/miq_request/_prov_vm_grid.html.erb_spec.rb
Comment 5 CFME Bot 2016-01-08 14:02:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=649f7612368bc4a0f2ed3fe7ca0f8d6fd8b70667

commit 649f7612368bc4a0f2ed3fe7ca0f8d6fd8b70667
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 17:03:37 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Jan 8 09:26:10 2016 -0500

    Fixed a typo in variable name in the link.
    
    - Added spec test to verify correct link is being built for rows in the grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283589
    https://bugzilla.redhat.com/show_bug.cgi?id=1296947
    (cherry picked from commit 751ff20)

 app/views/miq_request/_prov_vm_grid.html.haml      |  2 +-
 .../miq_request/_prov_vm_grid.html.erb_spec.rb     | 27 ++++++++++++++++++++++
 2 files changed, 28 insertions(+), 1 deletion(-)
 create mode 100644 spec/views/miq_request/_prov_vm_grid.html.erb_spec.rb
Comment 6 CFME Bot 2016-01-08 14:02:33 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=86642e29ac49914f36f730abd47c3227930d9032

commit 86642e29ac49914f36f730abd47c3227930d9032
Merge: c160de8 649f761
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Jan 8 13:40:00 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Jan 8 13:40:00 2016 -0500

    Merge branch '55z_pr_6095' into '5.5.z'
    
    Fixed a typo in variable name in the link.
    
    - Added spec test to verify correct link is being built for rows in the grid.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283589
    https://bugzilla.redhat.com/show_bug.cgi?id=1296947
    (cherry picked from commit 751ff20)
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6095
    
    See merge request !687

 app/views/miq_request/_prov_vm_grid.html.haml      |  2 +-
 .../miq_request/_prov_vm_grid.html.erb_spec.rb     | 27 ++++++++++++++++++++++
 2 files changed, 28 insertions(+), 1 deletion(-)
Comment 9 errata-xmlrpc 2016-06-29 11:10:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.