Bug 1283608 - nfs-ganesha: Upcall sent on null gfid
nfs-ganesha: Upcall sent on null gfid
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.1
All All
medium Severity medium
: ---
: RHGS 3.1.2
Assigned To: Soumya Koduri
Matt Zywusko
: ZStream
: 1278220 (view as bug list)
Depends On:
Blocks: 1260783 1278220 1283983 1287079
  Show dependency treegraph
 
Reported: 2015-11-19 07:08 EST by Soumya Koduri
Modified: 2016-06-20 19:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283983 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:56:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 05:20:36 EST

  None (edit)
Description Soumya Koduri 2015-11-19 07:08:21 EST
Description of problem:

During polling for cache-invalidation requests, gfapi sends lookup on root filehandle. Since root filehandle has null gfid, lookup fails with invalid argument and we shall end up having below log messages in gfapi.log.

[2015-11-13 08:34:50.471491] W [MSGID: 114031] [client-rpc-fops.c:2971:client3_3_lookup_cbk] 0-vol_prod_01-client-0: remote operation failed. Path: (null) (00000000-0000-0000-0000-000000000000) [Invalid argument]
[2015-11-13 08:34:50.472078] W [MSGID: 114031] [client-rpc-fops.c:2971:client3_3_lookup_cbk] 0-vol_prod_01-client-1: remote operation failed. Path: (null) (00000000-0000-0000-0000-000000000000) [Invalid argument]
[2015-11-13 08:34:50.472135] W [MSGID: 104011] [glfs-handleops.c:1291:pub_glfs_h_create_from_handle] 0-meta-autoload: inode refresh of 00000000-0000-0000-0000-000000000000 failed: Invalid argument [Invalid argument]
[2015-11-13 08:34:50.472168] E [glfs-handleops.c:1789:glfs_h_poll_cache_invalidation] (-->/usr/lib64/ganesha/libfsalgluster.so(GLUSTERFSAL_UP_Thread+0x20c) [0x7f6d5473eacb] -->/lib64/libgfapi.so.0(glfs_h_poll_upcall+0x190) [0x7f6d54324a10] -->/lib64/libgfapi.so.0(+0x1877c) [0x7f6d5432477c] ) 0-glfs_h_poll_cache_invalidation: invalid argument: object [Invalid argument]
[2015-11-13 08:34:50.472176] W [glfs-handleops.c:1944:pub_glfs_h_poll_upcall] 0-meta-autoload: handle creation of 00000000-0000-0000-0000-000000000000 failed: Invalid argument


Version-Release number of selected component (if applicable):
nfs-ganesha-2.2.0*

How reproducible:
Always


Steps to Reproduce:
1. Mount any volume via two different ganesha servers
2. Access root directory from both the mounts and perform some I/Os.

Actual results:
lookup failure on root filehandle error messages get logged

Expected results:
No such log messages should get logged
Comment 2 Soumya Koduri 2015-11-27 01:45:59 EST
Patch posted upstream - 

http://review.gluster.org/#/c/12773/
Comment 4 Saurabh 2015-12-09 04:38:41 EST
Verified on : glusterfs-3.7.5-10.el7rhgs.x86_64
Comment 7 errata-xmlrpc 2016-03-01 00:56:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html
Comment 8 Oonkwee Lim_ 2016-06-20 19:25:56 EDT
*** Bug 1278220 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.