Bug 1287079 - nfs-ganesha: Upcall sent on null gfid
nfs-ganesha: Upcall sent on null gfid
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
3.7.6
All All
unspecified Severity medium
: ---
: ---
Assigned To: Soumya Koduri
: Triaged, ZStream
Depends On: 1283608 1283983
Blocks: 1278220
  Show dependency treegraph
 
Reported: 2015-12-01 08:15 EST by Soumya Koduri
Modified: 2016-04-19 03:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283983
Environment:
Last Closed: 2016-02-05 06:31:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-01 10:14:40 EST
REVIEW: http://review.gluster.org/12839 (Upcall: Read gfid from iatt in case of invalid inode) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2015-12-03 17:52:45 EST
COMMIT: http://review.gluster.org/12839 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 45c2a17ce96d4802ddd2b36a5131b64caa8b1a3c
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Fri Nov 27 12:09:22 2015 +0530

    Upcall: Read gfid from iatt in case of invalid inode
    
    When any file/dir is looked upon for the first time, inode
    created shall be invalid till it gets linked to the inode table.
    In such cases, read the gfid from the iatt structure returned
    as part of such fops for UPCALL processing.
    
    This is backport of the below patch
     - http://review.gluster.org/12773
    
    Change-Id: Ie5eb2f3be18c34cf7ef172e126c9db5ef7a8512b
    BUG: 1287079
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12773
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/12839
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2016-04-19 03:49:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.