Bug 1283668 - 404 on /assets/Freebsd.png in Hosts -> Operating Systems
Summary: 404 on /assets/Freebsd.png in Hosts -> Operating Systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.4
Hardware: x86_64
OS: All
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-19 14:29 UTC by Oleksandr Shtaier
Modified: 2019-09-26 16:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:59:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Oleksandr Shtaier 2015-11-19 14:29:29 UTC
Description of problem:
When you have operating system with OS Family: FreeBSD, it misses icon.

Version-Release number of selected component (if applicable):
It seems that defect exists for a while

How reproducible:
Always

Steps to Reproduce:
1.Hosts -> Operating Systems -> New Operating System
     among others set OS Family: FreeBSD and submit


Actual results:
Icon is not displayed and next error is present in production.log:

ActionController::RoutingError (No route matches [GET] "/assets/Freebsd.png"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'


Expected results:
Icon should be visible

Additional info:
Similar to BZ 1106411

Comment 1 Bryan Kearney 2016-02-11 13:05:26 UTC
This is fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1106411

Comment 6 Roman Plevka 2016-04-04 13:52:26 UTC
VERIFIED
on sat6.2.0 snap6.1

- the icon is now showing and there are no errors in the console

Comment 8 errata-xmlrpc 2016-07-27 08:59:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.