Bug 128367 - Login does not inform users of expired passwords (gdm does)
Summary: Login does not inform users of expired passwords (gdm does)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 128366 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-22 07:59 UTC by Mike MacCana
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 09:14:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2004-07-22 07:59:58 UTC
Description of problem:
Login and GDM do not have consistent behavior with each other. Login
doesn't tell users that their password has expired. GDM does.

This could be fixed with a simple warning for login when a users
password has expired simialar to what gdm does "your account has
expired, please contact your system administrator".

Version-Release number of selected component (if applicable):
2.12a-2

How reproducible:
Always

Steps to Reproduce:
1.Log in using login as a user with an expired password
2.Compare to gdm
  
Actual results:
Its not consistent. And not particularly helpful either.

Expected results:
Login should be consistent with gdm and tell the user of the problem
so that they indeed contact the system admin, rather than trying
aimlessly.

Additional info:
Red Hat's training currently involves getting users to solve problems
with expired passwords - the inconsistency between gdm and login
doesn't look great. If someone who knows C better than I do could fix
login, that'd be great.

Thanks very much.

Mike

Comment 1 Mike MacCana 2004-07-22 08:45:40 UTC
*** Bug 128366 has been marked as a duplicate of this bug. ***

Comment 2 Karel Zak 2004-12-17 13:35:54 UTC
For example "rlogin" use auth by "login":

# /usr/bin/rlogin localhost -l longusername
Password:
Your account has expired; please contact your system administrator

This message reports pam_unix. I think everything other depend on your
system-auth setting.

Comment 3 Mike MacCana 2005-02-06 01:00:14 UTC
Correction: the message is displayed but disappears immediately. Is
there some way we could get it to display on screen for a few seconds
before login respawns (by default)?

Comment 4 Karel Zak 2005-04-20 09:14:41 UTC
see "man mingetty" (e.g. --noclear or --delay option) and /etc/inittab


Note You need to log in before you can comment on or make changes to this bug.