Bug 1283693 - RFE: Collect rabbitmq report(s) by default
RFE: Collect rabbitmq report(s) by default
Status: CLOSED DUPLICATE of bug 1310433
Product: Red Hat OpenStack
Classification: Red Hat
Component: sos (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: ---
: 8.0 (Liberty)
Assigned To: Lee Yarwood
BaseOS QE - Apps
: FutureFeature
: 1283694 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 10:27 EST by Lars Kellogg-Stedman
Modified: 2016-03-14 08:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 09:45:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-11-19 10:27:54 EST
The diagnostic information collected by sosreport does not currently included information necessary for debugging rabbitmq problems.  This almost invariably results in multiple round-trips to the customer as we ask them to provide the output of various commands.

For our OpenStack deployments we should be collecting, by default, at least the output of "rabbitmqctl report", and possibly the output of the various "rabbitmqctl list_*" commands.
Comment 2 Lee Yarwood 2015-11-19 11:05:00 EST
*** Bug 1283694 has been marked as a duplicate of this bug. ***
Comment 3 Lee Yarwood 2015-11-19 11:33:14 EST
(In reply to Lars Kellogg-Stedman from comment #0)
> The diagnostic information collected by sosreport does not currently
> included information necessary for debugging rabbitmq problems.  This almost
> invariably results in multiple round-trips to the customer as we ask them to
> provide the output of various commands.
> 
> For our OpenStack deployments we should be collecting, by default, at least
> the output of "rabbitmqctl report", and possibly the output of the various
> "rabbitmqctl list_*" commands.

Thanks for the report Lars, did you see this when running sos on an OSP 5 or 6 environment? Are you able to provide the version of sos you were using etc?

I ask as `rabbitmqctl report` should be collected with the forked versions of sos we currently ship with RHEL OSP 7 and plan to provide for OSP 5 & 6 shortly.

As for the `rabbitmqctl list_*` commands my understanding is that a report should already contain all of the data provided by these commands. If that isn't the case would you mind providing some examples and I'll get these added to the rabbitmq plugin.
Comment 4 Bryn M. Reeves 2015-11-19 11:47:50 EST
Upstream does this (in addition to logs & config):

    def setup(self):
        self.add_cmd_output("rabbitmqctl report")
        self.add_cmd_output("rabbitmqctl cluster_status")
        self.add_cmd_output("rabbitmqctl list_policies")

Is that sufficient?
Comment 5 Lars Kellogg-Stedman 2015-11-20 14:27:33 EST
Sure.  This request stemmed from a recent customer engagement in which we weren't getting any rabbitmq data, but the customer is running OSP 5 so that would explain it.

I guess getting these changes released in OSP 5 would make everybody happy.
Comment 6 Lee Yarwood 2016-02-21 09:45:53 EST
Apologies for the delay here, I'm closing this out as a duplicate of BZ#1310433 where I'll chase to get an updated version of sos into OSP 5 for RHEL 7 hosts.

*** This bug has been marked as a duplicate of bug 1310433 ***

Note You need to log in before you can comment on or make changes to this bug.