Bug 1283778 - Advanced configuration screen not expanding when editing
Advanced configuration screen not expanding when editing
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Dávid Halász
Ramesh A
:
Depends On:
Blocks: 1289337
  Show dependency treegraph
 
Reported: 2015-11-19 15:37 EST by Josh Carter
Modified: 2016-06-29 11:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289337 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:03:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot error (357.89 KB, image/png)
2015-11-19 15:39 EST, Josh Carter
no flags Details

  None (edit)
Description Josh Carter 2015-11-19 15:37:39 EST
Description of problem:

Attempting to edit an appliance's adv. configuration file via the UI
editor does not expand to the full section of the UI.

Advanced configuration screen not expanding when editing.

Version-Release number of selected component (if applicable):
5.5.0.9 beta 2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Josh Carter 2015-11-19 15:39 EST
Created attachment 1096899 [details]
screen shot error
Comment 3 Harpreet Kataria 2015-11-24 18:23:20 EST
Eric,

Can you look into this one.

Thanks,
~Harpreet
Comment 5 Dávid Halász 2015-12-02 09:19:26 EST
https://github.com/ManageIQ/manageiq/pull/5656
Comment 6 CFME Bot 2015-12-02 14:46:46 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c40449b0ba70a01c47abe050c4efa5e6e5a77a48

commit c40449b0ba70a01c47abe050c4efa5e6e5a77a48
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Tue Dec 1 10:45:08 2015 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Wed Dec 2 11:18:45 2015 +0100

    Refactored javascript for codemirror + adjusted autosizing
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283778

 app/views/catalog/explorer.html.haml        |  4 ++--
 app/views/layouts/_my_code_mirror.html.haml | 33 +++++++++++++++++------------
 app/views/ops/explorer.html.haml            | 12 ++++-------
 3 files changed, 25 insertions(+), 24 deletions(-)
Comment 7 CFME Bot 2015-12-07 17:28:55 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=aaa5c53e97d42cf65eda5396cf057e2d7bb2bfec

commit aaa5c53e97d42cf65eda5396cf057e2d7bb2bfec
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Tue Dec 1 10:45:08 2015 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Wed Dec 2 15:19:40 2015 +0100

    Refactored javascript for codemirror + adjusted autosizing
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283778
    (cherry picked from commit c40449b0ba70a01c47abe050c4efa5e6e5a77a48)

 app/views/catalog/explorer.html.haml        |  4 ++--
 app/views/layouts/_my_code_mirror.html.haml | 33 +++++++++++++++++------------
 app/views/ops/explorer.html.haml            | 12 ++++-------
 3 files changed, 25 insertions(+), 24 deletions(-)
Comment 8 CFME Bot 2015-12-07 17:29:04 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4fc885f3d97a4c0d148efa51f5b8c545741362ba

commit 4fc885f3d97a4c0d148efa51f5b8c545741362ba
Merge: 2055264 aaa5c53
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 17:27:14 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 17:27:14 2015 -0500

    Merge branch 'bz-1283778' into '5.5.z'
    
    Refactored javascript for codemirror + adjusted autosizing
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283778
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1289337
    
    Clean cherrypick from: https://github.com/ManageIQ/manageiq/pull/5656
    (cherry picked from commit c40449b0ba70a01c47abe050c4efa5e6e5a77a48)
    
    See merge request !570

 app/views/catalog/explorer.html.haml        |  4 ++--
 app/views/layouts/_my_code_mirror.html.haml | 33 +++++++++++++++++------------
 app/views/ops/explorer.html.haml            | 12 ++++-------
 3 files changed, 25 insertions(+), 24 deletions(-)
Comment 9 Ramesh A 2016-04-22 08:58:30 EDT
Good to go. Verified and working fine in 5.6.0.4-beta2.3.20160421172650_719e256
Comment 11 errata-xmlrpc 2016-06-29 11:03:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.