Bug 1283840 - Evince-3.18.0-1 cannot select text in any PDF document
Evince-3.18.0-1 cannot select text in any PDF document
Status: CLOSED DUPLICATE of bug 1287402
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 23:55 EST by Peter
Modified: 2015-12-15 11:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 11:49:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter 2015-11-19 23:55:06 EST
Description of problem:

Unable to properly (or correctly) select desired text content (i.e., words, sentences, paragraphs, etc.) by dragging the mouse pointer on any PDF type document opened by Evince.

Version-Release number of selected component (if applicable):

evince-3.18.0-1.fc23.x86_64
(Document viewer)

How reproducible:

Always.

Steps to Reproduce:
1. Start Evince Document viewer application.
2. Open any PDF type document.
3. Using the mouse -- click any section of the PDF document and drag to select the specific text content.


Actual results:

Only a portion of the text is selected -- even before the mouse button is released.

Expected results:

All of the specific text content should be selected when the mouse button is released.

Additional info:

I first noticed this problem just after upgrading Fedora from FC22 to FC23.

[root@mypc ~]# lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID:	Fedora
Description:	Fedora release 23 (Twenty Three)
Release:	23
Codename:	TwentyThree
Comment 1 Marek Kašík 2015-12-15 11:49:14 EST
This looks like the problem from the #1287402.

*** This bug has been marked as a duplicate of bug 1287402 ***

Note You need to log in before you can comment on or make changes to this bug.