Bug 1287402 - Selecting text of a pdf in Evince doesn't work under Wayland
Selecting text of a pdf in Evince doesn't work under Wayland
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
: 1283840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 21:39 EST by 汪明衡
Modified: 2015-12-18 02:52 EST (History)
5 users (show)

See Also:
Fixed In Version: evince-3.18.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 02:52:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 759506 None None None Never

  None (edit)
Description 汪明衡 2015-12-01 21:39:28 EST
Description of problem:
I'm running Fedora 23. Under Gnome Wayland when I select pdf text in Evince the highlighted text back to normal as long as I release left mouse button, which makes it impossible to select text and right click to copy it. Though pressing CTRL+C when holding left button still copies the text.

Version-Release number of selected component (if applicable):


How reproducible:
Completely reproducible on my machine.

Steps to Reproduce:
1. Open a pdf file;
2. Left click to select some text;
3. release left button

Actual results:


Expected results:


Additional info:
Comment 1 flavio.l 2015-12-15 08:10:03 EST
Exactly the same issue, 
Fedora 23 Gnome Wayland updated as of today.

Wayland is working great apart from small issues.
However, this issue with text selection is quite annoying for any desktop user.
Please fix.
+1
Comment 2 Marek Kašík 2015-12-15 11:49:14 EST
*** Bug 1283840 has been marked as a duplicate of this bug. ***
Comment 3 Marek Kašík 2015-12-15 11:52:48 EST
Hi,

I've reported this upstream together with a patch. See https://bugzilla.gnome.org/show_bug.cgi?id=759506. I'll prepare an update for this.
Comment 4 Fedora Update System 2015-12-15 12:39:06 EST
evince-3.18.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7cee96f984
Comment 5 Fedora Update System 2015-12-16 20:59:54 EST
evince-3.18.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update evince'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7cee96f984
Comment 6 Fedora Update System 2015-12-18 02:52:34 EST
evince-3.18.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.