Bug 1283940 - Data Tiering: new set of gluster v tier commands not working as expected
Data Tiering: new set of gluster v tier commands not working as expected
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity high
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
nchilaka
: Regression, ZStream
Depends On:
Blocks: 1260783 1288517 1291970
  Show dependency treegraph
 
Reported: 2015-11-20 06:07 EST by nchilaka
Modified: 2016-09-17 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288517 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:56:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server logs (29.09 KB, application/vnd.oasis.opendocument.text)
2015-12-20 08:40 EST, Sweta Anandpara
no flags Details

  None (edit)
Description nchilaka 2015-11-20 06:07:14 EST
Description of problem:
=====================
In a effort to make the cli more organised, we had some fixes, where all tiering commands will come under "gluster v tier"
But with this all the expected o/p errors/messages have not be updated accordinly wrt to the older cli.
There is a disparity on the older cli o/p and new cli o/p
We need to have this fixed, as it will lead to unncessary regressions both from feature perspective and for automation cases.

Following are the examples(there are more):
==========================
1)detach tier status on non tier volume
old:
[root@zod distrep]# gluster v detach-tier clitest  status
volume detach-tier status: failed: volume clitest is not a tier volume.
Tier command failed
New:
[root@zod distrep]# gluster v tier clitest detach status
                                    Node Rebalanced-files          size       scanned      failures       skipped               status   run time in secs
                               ---------      -----------   -----------   -----------   -----------   -----------         ------------     --------------

2)detach tier stop on non tier volume:
old:
[root@zod distrep]# gluster v detach-tier clitest  stop
volume detach-tier stop: failed: volume clitest is not a tier volume.
Tier command failed

new:
[root@zod distrep]# gluster v tier clitest detach stop
                                    Node Rebalanced-files          size       scanned      failures       skipped               status   run time in secs
                               ---------      -----------   -----------   -----------   -----------   -----------         ------------     --------------
'detach-tier' process may be in the middle of a file migration.
The process will be fully stopped once the migration of the file is complete.



Version-Release number of selected component (if applicable):
==============================
[root@zod distrep]# rpm -qa|grep gluster
glusterfs-libs-3.7.5-6.el7rhgs.x86_64
glusterfs-fuse-3.7.5-6.el7rhgs.x86_64
glusterfs-3.7.5-6.el7rhgs.x86_64
glusterfs-server-3.7.5-6.el7rhgs.x86_64
glusterfs-client-xlators-3.7.5-6.el7rhgs.x86_64
glusterfs-cli-3.7.5-6.el7rhgs.x86_64
glusterfs-api-3.7.5-6.el7rhgs.x86_64
glusterfs-debuginfo-3.7.5-6.el7rhgs.x86_64




NOTE:Kindly analyze all the possible options in new cli and change them accordingly
Comment 2 nchilaka 2015-11-24 11:50:19 EST
we need to take care of the parity like bug#1279350, which was fixed, but cannot be said that it is validated against new cli as the o/p is different
Comment 4 Vivek Agarwal 2015-12-17 04:28:22 EST
https://code.engineering.redhat.com/gerrit/63889
Comment 5 Sweta Anandpara 2015-12-20 08:40:05 EST
Tested and verified this on the build glusterfs-3.7.5-12.el7rhgs.x86_64

Mapped the commands and the corresponding outputs of:

'gluster v tier attach/detach' alongside
'gluster v tier-attach' and 'gluster v tier-detach' 

at various stages of tier lifecycles and found them to be similar.

Moving the present bug to verified in 3.1.2. Detailed logs are attached.
Comment 6 Sweta Anandpara 2015-12-20 08:40 EST
Created attachment 1107976 [details]
server logs
Comment 9 errata-xmlrpc 2016-03-01 00:56:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.