Bug 1291970 - Data Tiering: new set of gluster v tier commands not working as expected
Data Tiering: new set of gluster v tier commands not working as expected
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1283940 1288517
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 00:21 EST by hari gowtham
Modified: 2016-04-19 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288517
Environment:
Last Closed: 2016-04-19 03:51:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-16 00:28:15 EST
REVIEW: http://review.gluster.org/12976 (tier/glusterd : making new tier detach command throw warning) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-12-16 03:49:40 EST
REVIEW: http://review.gluster.org/12976 (tier/glusterd : making new tier detach command throw warning) posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-12-16 12:28:33 EST
COMMIT: http://review.gluster.org/12976 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 5f6baf2cb061fd32a35bff2081b8ba966871e39d
Author: hari gowtham <hgowtham@redhat.com>
Date:   Fri Dec 4 18:34:36 2015 +0530

    tier/glusterd : making new tier detach command throw warning
    
            back port of : http://review.gluster.org/#/c/12883/
    
    For detach tier, the validation was done using the string "detach-tier"
    but the new commands used has the string "tier". Making the string use
    "tier" to compare, creates problem as the tier status and tier detach
    have the keyword "tier". So tier detach and tier status were separated.
    and strtok was used to prevent the condition from passing when the
    volume name has a substring of "tier". (only the second word from the
    string is got and checked if the feature is tier).
    
    Problem: new detach tier command doesnt throw warnings like
    "not a tier volume" or " detach tier not started" respectively
    instead it prints empty output.
    
    Fix: while validate the volume is checked if its a tiered volume
    if yes it is checked if the detach tier is started, else a warning
    is thrown respectively.
    
    >Change-Id: I94246d53b18ab0e9406beaf459eaddb7c5b766c2
    >BUG: 1288517
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: http://review.gluster.org/12883
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I1ac3b6baaec644dbc2025085a7f17abd56ba169d
    BUG: 1291970
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12976
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 03:51:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.