This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1284016 - Cloudform fail to had and openstack if one endpoint not repond
Cloudform fail to had and openstack if one endpoint not repond
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Dave Johnson
:
Depends On:
Blocks: 1289744
  Show dependency treegraph
 
Reported: 2015-11-20 09:40 EST by kpichard
Modified: 2016-01-12 05:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289744 (view as bug list)
Environment:
Last Closed: 2016-01-12 05:55:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kpichard 2015-11-20 09:40:28 EST
Description of problem: Cloudform is not able to finish adding an openstack if one of the component endpoint not responding.


Version-Release number of selected component (if applicable): 5.4.3.1


How reproducible: Attach an openstack where one of the component isn't reponding
You can use an osp-d to reproduce this issue : https://bugzilla.redhat.com/show_bug.cgi?id=1283905

Steps to Reproduce: 
1. deploy an openstack with osp-d following the bug bellow, or comment the haproxy listen from configuration of each controllers.
2. Add a new cloud provider Openstack
3. Information of this cloud will never be displayed because it fail on interrogating one of the endpoint :

tail /var/www/miq/vmdb/log/fog.log -f

[----] D, [2015-11-20T09:35:02.133323 #2494:ab7ea8] DEBUG -- : excon.request   
{:uri=>"http://10.41.18.20:8080/v1/AUTH_92d1b60d737a4bdb96eb3894bc8a4eb2/",
 :query=>{"format"=>"json"},
 :method=>"GET",
 :headers=>
  {"User-Agent"=>"fog/1.29.0 fog-core/1.32.1",
   "Content-Type"=>"application/json",
   "Accept"=>"application/json",
   "X-Auth-Token"=>"309873e9c7ac446a8af449e5247d25b0",
   "Host"=>"10.41.18.20:8080"},
 :body=>nil}

[----] E, [2015-11-20T09:35:02.135316 #2494:ab7ea8] ERROR -- : excon.error     #<Excon::Errors::SocketError: Connection refused - connect(2) (Errno::ECONNREFUSED)>

Interface display : 
Default Credentials	Valid
Last Refresh	
Error - 4 Minutes Ago
Connection refused - connect(2) (Errno::ECONNREFUSED

Actual results:
Cloudform stop the scan and let the cloudprovider as unknown while it has information of tenants, vm ....

Expected results:
It should warn and skip the missing element.

Additional info:
Comment 2 Marius Cornea 2016-01-12 05:55:32 EST
All stated keystone endpoints must be reachable in order for refresh to finish. This looks to be caused by BZ#1237009.

Note You need to log in before you can comment on or make changes to this bug.