Bug 1284110 - Migrate VM : NoMethodError: undefined method `vm'
Migrate VM : NoMethodError: undefined method `vm'
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Lucy Fu
Nandini Chandra
: ZStream
: 1304015 (view as bug list)
Depends On:
Blocks: 1289619
  Show dependency treegraph
 
Reported: 2015-11-20 16:39 EST by Lucy Fu
Modified: 2016-06-29 11:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289619 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:10:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucy Fu 2015-11-20 16:39:07 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. choose and VM and under Lifecycle "Migrate this VM"
2. Fill all fields and select host and datastore 
3. Check the error messages in the log

Actual results:
Vm was migrated but failed to email the owner.

Expected results:
The Owner should get an email about the successful VM migration.

Additional info:
Vm was migrated but failed to email the owner with following error messages:

[----] E, [2015-11-16T16:50:08.319886 #8464:3bd196c] ERROR -- : Q-task_id([vm_migrate_task_1000000000001]) <AutomationEngine> <AEMethod vmmigratetask_complete>   NoMethodError: undefined method `vm' for #<MiqAeMethodService::MiqAeServiceVmMigrateTask:0x00000007674fb0>
[----] E, [2015-11-16T16:50:08.320897 #8464:3bd196c] ERROR -- : Q-task_id([vm_migrate_task_1000000000001]) <AutomationEngine> <AEMethod vmmigratetask_complete>   (druby:     //127.0.0.1:40434) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:176:in `method_missing'
(druby://127.0.0.1:40434) /opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1588:in `perform_without_block'
(druby://127.0.0.1:40434) /opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1548:in `perform'
(druby://127.0.0.1:40434) /opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1626:in `block (2 levels) in main_loop'
(druby://127.0.0.1:40434) /opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1622:in `loop'
(druby://127.0.0.1:40434) /opt/rh/ruby200/root/usr/share/ruby/drb/drb.rb:1622:in `block in main_loop'
(druby://127.0.0.1:40434) /var/www/miq/vmdb/lib/extensions/ar_thread.rb:22:in `block in start_with_release'
[----] E, [2015-11-16T16:50:08.326401 #8464:3bbe3f8] ERROR -- : Q-task_id([vm_migrate_task_1000000000001]) <AutomationEngine> Method STDERR: (druby://127.0.0.1:40434) /var/www/miq/vmdb/lib/miq_automation_engine/engine/miq_ae_service_model_base.rb:176:in `method_missing': undefined method `vm' for #<MiqAeMethodService::MiqAeServiceVmMigrateTask:0x00000007674fb0> (NoMethodError)
Comment 4 CFME Bot 2015-12-07 17:45:25 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/823b9fe4abbc8b74d1432dc84475159581e1536e

commit 823b9fe4abbc8b74d1432dc84475159581e1536e
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Fri Nov 20 16:42:59 2015 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Mon Dec 7 15:52:47 2015 -0500

    The VM information is kept in miq_migrate_task as source.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284110

 .../__methods__/vmmigratetask_complete.rb           | 21 +--------------------
 1 file changed, 1 insertion(+), 20 deletions(-)
Comment 5 CFME Bot 2015-12-07 17:45:29 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/de7e9ce60b6c009c0fa6a36fd6a51b98f94b7a73

commit de7e9ce60b6c009c0fa6a36fd6a51b98f94b7a73
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Fri Dec 4 15:41:38 2015 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Mon Dec 7 16:02:48 2015 -0500

    Add test case for automate method vmmigratetask_complete.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284110

 .../vm_migrate_task_complete_spec.rb               | 23 ++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 spec/automation/unit/method_validation/vm_migrate_task_complete_spec.rb
Comment 6 CFME Bot 2015-12-09 08:59:52 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c60d007835b91addd79eff7b5e37bdcebe35dacd

commit c60d007835b91addd79eff7b5e37bdcebe35dacd
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Fri Dec 4 15:41:38 2015 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Dec 8 10:39:11 2015 -0500

    Add test case for automate method vmmigratetask_complete.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284110

 .../vm_migrate_task_complete_spec.rb               | 23 ++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 spec/automation/unit/method_validation/vm_migrate_task_complete_spec.rb
Comment 7 CFME Bot 2015-12-09 08:59:56 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=eb8ff6c81ce5e776ca54240d19eb2881ffaeb3d8

commit eb8ff6c81ce5e776ca54240d19eb2881ffaeb3d8
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Fri Nov 20 16:42:59 2015 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Dec 8 10:38:55 2015 -0500

    The VM information is kept in miq_migrate_task as source.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284110

 .../__methods__/vmmigratetask_complete.rb           | 21 +--------------------
 1 file changed, 1 insertion(+), 20 deletions(-)
Comment 8 Greg McCullough 2016-02-02 14:32:05 EST
*** Bug 1304015 has been marked as a duplicate of this bug. ***
Comment 9 Nandini Chandra 2016-04-25 23:43:57 EDT
Verified in 5.6.0.4
Comment 11 errata-xmlrpc 2016-06-29 11:10:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.