Bug 1284341 - config.yaml needs to be removed
config.yaml needs to be removed
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
5.0
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 1174069 (view as bug list)
Depends On: 1225107 1324287 1326559 1326979 1326981
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 23:57 EST by Jeff Fearn
Modified: 2016-09-11 20:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-11 20:38:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1250786 None None None 2016-02-24 19:38 EST

  None (edit)
Description Jeff Fearn 2015-11-22 23:57:37 EST
Description of problem:
This file should go away and the data should be either moved to the DB or the para.json file as appropriate.
Comment 1 Jason McDonald 2015-11-23 00:06:25 EST
I vote for moving to the database and making it editable via the Admin UI so that editing the default bug description templates can be self-service for product owners.
Comment 2 Jeff Fearn 2015-11-23 00:09:30 EST
(In reply to Jason McDonald from comment #1)
> I vote for moving to the database and making it editable via the Admin UI so
> that editing the default bug description templates can be self-service for
> product owners.

There is a separate bug for that specific component of config.yaml
Comment 5 Matt Tyson 2016-02-29 00:47:36 EST
*** Bug 1174069 has been marked as a duplicate of this bug. ***
Comment 6 Hui Wang 2016-03-22 03:37:23 EDT
Verified the issue.
version 5.0.2.rh2
The result is FAILED.

The config.yaml file still exist under data/ . 
The data, like doc_type_text, that you have mentioned in comment #3, should be moved to database or data/params.json, right?  I can see the data items you mentioned in comment #3 still exist in data/config.yaml.
Comment 7 Jeff Fearn 2016-04-25 19:58:04 EDT
This bug will be used to eliminate the code that loads and parses config.yaml
Comment 8 Jeff Fearn 2016-05-12 02:35:46 EDT
Hi Muhammad, the last remaining blocker for this bug is Bug 1225107 which is not in this sprint. What to do?
Comment 9 Muhammad Tahir 2016-05-12 20:28:58 EDT
Bug 1225107 moved to current sprint.
Comment 10 Rony Gong 2016-08-08 02:39:22 EDT
Tested on QA environment(5.0.3-rh4)
Result: Pass

Note You need to log in before you can comment on or make changes to this bug.