Bug 1284364 (RHV_DR) - [RFE][Tracker] recovery manager for disaster recovery in RHV
Summary: [RFE][Tracker] recovery manager for disaster recovery in RHV
Keywords:
Status: CLOSED ERRATA
Alias: RHV_DR
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.5.0
Hardware: All
OS: All
high
urgent
Target Milestone: ovirt-4.2.3
: ---
Assignee: Tal Nisan
QA Contact: Elad
URL: http://www.ovirt.org/develop/projects...
Whiteboard:
: 890655 1021066 1117056 1395763 (view as bug list)
Depends On: 1193961 1205739 1393839 1451018 1458745 1460513
Blocks: 1181636 1534978
TreeView+ depends on / blocked
 
Reported: 2015-11-23 07:20 UTC by Gajanan
Modified: 2021-08-30 13:35 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1534978 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:36:24 UTC
oVirt Team: Storage
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1489232 0 urgent CLOSED [Docs][RFE] Document Active-Active Disaster Recovery failover using a stretch cluster 2021-06-10 13:04:15 UTC
Red Hat Knowledge Base (Solution) 2044903 0 None None None 2017-10-30 00:53:14 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:38:04 UTC

Description Gajanan 2015-11-23 07:20:53 UTC
============= RFE REQUEST ================

1. Proposed title of this feature request

SRM - site recovery manager for disaster recovery in RHEV

3. What is the nature and description of the request?

Customer is looking for a feature like VMware site recovery manager for  disaster recovery. Like taking a VM from on RHEV site and failing it over to another. VMware uses a tool called SRM which creates a plan that will break our snapmirror (NetApp NAS/SAN) between the Prod and DR site and will mount once broken. 

https://www.vmware.com/products/site-recovery-manager

Customer wants this feature for RHEV. 


4. Why does the customer need this? (List the business requirements here)

> To failover our Production environment to our Disaster recovery site.

5. How would the customer like to achieve this? (List the functional requirements here)

> A pluging that would see both our storage devices (netapp filers) on both end (RHEV prod, RHEV colo) that would allow us to create a recovery plan and automatically spin up the VMs when the plan is initiated. This would see the array replication and make corrective actions when needed.

https://www.youtube.com/watch?v=kgZ62GS21Vc (great video on how SRM works)


6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

> No

8. Does the customer have any specific timeline dependencies and which release would they like to target ?

> None, we have a manual way of doing it now. Breaking a snapmirror and turning the host on the other side.

9. Is the sales team involved in this request and do they have any additional input?

10. List any affected packages or components.

11. Would the customer be able to assist in testing this functionality if implemented?

>  Possibly, depending if this does not affect our production environment.

Comment 2 Yaniv Lavi 2016-01-10 15:43:33 UTC
*** Bug 890655 has been marked as a duplicate of this bug. ***

Comment 3 Yaniv Lavi 2016-01-10 15:59:45 UTC
*** Bug 1021066 has been marked as a duplicate of this bug. ***

Comment 6 Oved Ourfali 2016-01-31 17:21:23 UTC
*** Bug 1117056 has been marked as a duplicate of this bug. ***

Comment 11 Yaniv Lavi 2017-06-13 09:04:47 UTC
*** Bug 1395763 has been marked as a duplicate of this bug. ***

Comment 15 Elad 2018-05-10 20:24:04 UTC
Site to site:
Covered all the feature's functionality, including fail over and fail back (which include generate mapping and validator). According to Polarion test plan external tracker attached.


Used:
ovirt-ansible-disaster-recovery-0.4-1.el7ev.noarch
ansible-2.5.2-1.el7ae.noarch


Active active:
Certified according to https://docs.google.com/document/d/1-ZWco1Z-BcTJezqSGhdQC9gBSC79sw9cDiq7Dfx_czE/edit

Comment 18 errata-xmlrpc 2018-05-15 17:36:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 19 Franta Kust 2019-05-16 13:07:57 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.