Bug 128438 - vim spills "unknown" escape sequences
vim spills "unknown" escape sequences
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-07-22 17:24 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-22 18:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-07-22 17:24:53 EDT
Description of problem:

With recent versions of vim opening a file, say 'vi /etc/fstab',
in a gnome-terminal or from a remote connection dumps
"^[34m~" right below end of text and no text colouring occures.
This is not the case on a text console.

The problem is also absent with vim-6.2.457-1 from FC2;
that means that neither gnome-terminal nor remotes show
any extra "enhancements".  Also using explicitely /bin/vi
from 'vim-minimal' prevents garbage from showing up for
a price of loosing various features of vim.

Version-Release number of selected component (if applicable):

How reproducible:
with any file
Comment 1 Karsten Hopp 2004-07-22 18:54:00 EDT
already fixed in vim-6.3.014-1 (bug 128344) 

Note You need to log in before you can comment on or make changes to this bug.