Bug 1284419 - Resource leak in marker
Resource leak in marker
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: marker (Show other bugs)
mainline
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: Triaged
Depends On:
Blocks: 1284850
  Show dependency treegraph
 
Reported: 2015-11-23 05:10 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1284850 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-11-23 05:10:40 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Manikandan 2015-11-23 05:12:35 EST
There is a resource leak in marker code, marker_readdirp_cbk().
Comment 2 Vijay Bellur 2015-11-23 05:38:52 EST
REVIEW: http://review.gluster.org/12719 (marker : fixing memory leak issue in marker) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2015-11-23 14:03:28 EST
COMMIT: http://review.gluster.org/12719 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f2287d00c7dc9c088860c12191ff760586889dde
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Nov 23 15:58:42 2015 +0530

    marker : fixing memory leak issue in marker
    
    In marker_readdirp_cbk, variable resolvedpath is not properly freed
    and because of which there was a memory leak. The patch fixes it.
    
    Change-Id: I9d80f72e3551aa912369257da3e8e2b261a2067f
    BUG: 1284419
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12719
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:46:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.