Bug 1284850 - Resource leak in marker
Resource leak in marker
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: marker (Show other bugs)
3.7.6
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: Triaged
Depends On: 1284419
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-24 05:51 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284419
Environment:
Last Closed: 2016-02-16 03:38:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-11-24 05:51:45 EST
+++ This bug was initially created as a clone of Bug #1284419 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Manikandan on 2015-11-23 05:12:35 EST ---

There is a resource leak in marker code, marker_readdirp_cbk().

--- Additional comment from Vijay Bellur on 2015-11-23 05:38:52 EST ---

REVIEW: http://review.gluster.org/12719 (marker : fixing memory leak issue in marker) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-23 14:03:28 EST ---

COMMIT: http://review.gluster.org/12719 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit f2287d00c7dc9c088860c12191ff760586889dde
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Nov 23 15:58:42 2015 +0530

    marker : fixing memory leak issue in marker
    
    In marker_readdirp_cbk, variable resolvedpath is not properly freed
    and because of which there was a memory leak. The patch fixes it.
    
    Change-Id: I9d80f72e3551aa912369257da3e8e2b261a2067f
    BUG: 1284419
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12719
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 1 Vijay Bellur 2015-11-24 06:00:23 EST
REVIEW: http://review.gluster.org/12733 (marker : fixing memory leak issue in marker) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-11-24 22:13:34 EST
COMMIT: http://review.gluster.org/12733 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit a058fb06aa8591d61eab8b1b95c74740938263b7
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Nov 23 15:58:42 2015 +0530

    marker : fixing memory leak issue in marker
    
    In marker_readdirp_cbk, variable resolvedpath is not properly freed
    and because of which there was a memory leak. The patch fixes it.
    
            Backport of http://review.gluster.org/#/c/12719/
    
    > Change-Id: I9d80f72e3551aa912369257da3e8e2b261a2067f
    > BUG: 1284419
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/12719
    > Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    Change-Id: I9d80f72e3551aa912369257da3e8e2b261a2067f
    BUG: 1284850
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12733
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:49:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.