Bug 1284427 - Appliances originally running 5.3.0 are using automations not present in their current release even after reset of the datastore
Appliances originally running 5.3.0 are using automations not present in thei...
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
All All
medium Severity medium
: GA
: 5.5.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
: 1284426 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 05:19 EST by Felix Dewaleyne
Modified: 2015-11-26 09:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 09:26:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff -r -q affected_datastore_extracted non_affected_datastore_extracted.out (31.24 KB, text/plain)
2015-11-23 05:19 EST, Felix Dewaleyne
no flags Details
datastore_affected.zip (480.08 KB, application/zip)
2015-11-23 05:43 EST, Felix Dewaleyne
no flags Details
datastore sample from a 5.4.3.1 appliance.zip (455.36 KB, application/zip)
2015-11-23 05:44 EST, Felix Dewaleyne
no flags Details

  None (edit)
Description Felix Dewaleyne 2015-11-23 05:19:22 EST
Created attachment 1097611 [details]
diff -r -q affected_datastore_extracted non_affected_datastore_extracted.out

Description of problem:
Appliances originally running 5.3.0 are using automations not present in their current release even after reset of the appliance's datastores

Version-Release number of selected component (if applicable):
5.4.3.1

How reproducible:
all the time

Steps to Reproduce:
1. install a 5.3.0 appliance
2. create a sample automation
3. upgrade to 5.4 using the documented path from the release notes
4. reset the datastore

Actual results:
in the ManageIQ and RedHat automations, content dating from 5.3.0 will continue to be present even after reset of the appliance datastore, such as /ManageIQ/Infrastructure/VM/Retirement/

Expected results:
the datastore of ManageIQ and RedHat are comparable to the contents of a deployed 5.4.3.1 (if 5.4.3.1 is the level the apppliance is updated to)

Additional info:
Comment 3 Felix Dewaleyne 2015-11-23 05:31:21 EST
note : to reset the datastore the UI is used.
Comment 4 Felix Dewaleyne 2015-11-23 05:43 EST
Created attachment 1097613 [details]
datastore_affected.zip

datastore affected - export taken after reset.
Comment 5 Felix Dewaleyne 2015-11-23 05:44 EST
Created attachment 1097614 [details]
datastore sample from a 5.4.3.1 appliance.zip

attaching the datastores used to generate the diff as well
Comment 6 Felix Dewaleyne 2015-11-23 05:56:31 EST
*** Bug 1284426 has been marked as a duplicate of this bug. ***
Comment 7 mkanoor 2015-11-23 10:06:50 EST
Hi,
Could you please provide the logs after you done the reset from the UI.
Thanks,
Madhu
Comment 8 Tina Fitzgerald 2015-11-23 17:46:27 EST
Hi Felix,

Do you have an environment setup to reproduce this issue?  If so, can I access it?

Thanks,
Tina
Comment 11 Tina Fitzgerald 2015-11-24 12:30:45 EST
While I investigate your issue further, there are rake tasks that might help you in the meantime. You can import and export the domains you want.

Detail about the import/export commands:
rake evm:automate:usage

sample export
rake evm:automate:export DOMAIN=ManageIQ EXPORT_AS=different_name_here_if_you_want EXPORT_DIR=./db/fixtures/ae_datastore

sample import
rake evm:automate:import DOMAIN=ManageIQ PREVIEW=false IMPORT_AS=can_rename_it_here_as_well IMPORT_DIR=./db/fixtures/ae_datastore
Comment 12 Felix Dewaleyne 2015-11-25 06:53:48 EST
thanks for the commands - it may interest you that for cfme-5.4.2.0 deployed systems updated to 5.4.3.1 the /var/www/miq/vmdb/db/fixues/ae_database/ManageIQ content does show the /ManageIQ/Infrastructure/VM/Retirement/StateMachines/Methods.class/startretirement.rb but that is not showing up in the automation explorer at all.
Comment 16 Tina Fitzgerald 2015-11-25 17:02:18 EST
Hi Felix,

I'm still investigating your issue, but there are few things I'd like to mention.

My understanding of the attached datastores.
datastore sample 5.4.3.1 - initial 5.4.3.1 pristine datastore
datastore affected - after reset

The datastore contents look like they're reversed using the count of instances and methods for /Infrastructure/VM/Retirement/StateMachines/Methods(I'll refer to that as IVRSM) as an indication. It almost looks like you started with 5.2.0.0. and the datastore reset did the right thing and brought it to the 5.4.3.1 level.

datastore sample 5.4.3.1 IVRSM - 7 instances/ 8 methods  
datastore affected IVRSM -  11 instances/ 9 methods

I've attached the ManageIQ domains for versions 5.3.0.0, 5.4.2.0, and 5.4.3.1 which I've gotten from checking out the various branches.

5.4.3.1 IVRSM - 11 instances / 9 methods
5.4.2.0 IVRSM - 11 instances / 9 methods
5.3.0.0 IVRSM -  7 instances / 8 methods

vm-207's ManageIQ domain has the IVRSM 11/9 count like it should and the preserved ManageIQ_5.4.3.1 IVRSM counts of 7/8 look like that of the 5.3.0.0 version.

We're on holiday for a few days, but I'll check in on the ticket.

Regards,
Tina
Comment 21 Felix Dewaleyne 2015-11-26 09:27:19 EST
my reference system was not in the state I thought it was - closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.