Bug 1284577 - New RHSM repos do not appear as expected
New RHSM repos do not appear as expected
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Scott Dodson
libra bugs
: Triaged, UpcomingRelease
Depends On:
Blocks: 1297059
  Show dependency treegraph
 
Reported: 2015-11-23 10:46 EST by Scott Dodson
Modified: 2016-04-08 11:29 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1297059 (view as bug list)
Environment:
Last Closed: 2016-04-08 11:29:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2015-11-23 10:46:01 EST
Description of problem:
Last Thursday a new channel in RHSM was created, 'rhel-7-server-ose-3.1-rpms', without re-registering a system this channel does not show up.


Version-Release number of selected component (if applicable):
subscription-manager-1.15.9-15.el7.x86_64

How reproducible:
Seems like 100% though it's hard to test because you have to have a system that was registered prior to the new channel being created so if you register a system now it won't show up.

Steps to Reproduce:
1. Register a system via rhsm
2. Have a new repo created
3. Attempt to attach to that repo

Actual results:
New repo doesn't show up

Expected results:
new repo shows up

Additional info:
Remove and attach seems to work as a workaround but does remove free up the entitlement in RHSM?

subscription-manager remove --serial=###
subscription-manager attach --pool=###
Comment 2 Scott Dodson 2015-11-23 10:47:16 EST
subscription-manager refresh has no effect
Comment 3 Brenton Leanhardt 2015-12-03 09:46:22 EST
We're still hearing reports of customers hitting this.  Can this be given some priority?  I suspect we'll hit this problem for every OpenShift release.
Comment 4 Chris Rog 2016-01-14 10:49:42 EST
Having a bit of trouble reproducing this. The only thing I could do to generate a similar situation was adding a subscription to a backing pre-2.0 Candlepin instance after a consumer had registered with subman (so far this sounds about right). I was able to resolve the issue by performing a refresh_pools operation on Candlepin directly. At that point, the new subscription started showing up in `subscription-manager list --available` and clients were able to attach to it fine.

Where I think we're deviating a bit is that it looks like you already have a pool ID, which implies a refresh had already been done to cause the new pool to be generated.
Comment 5 Scott Dodson 2016-01-25 09:37:10 EST
Sorry, I really don't have a good idea of the candlepin side of things here, just that as an end user of RHSM managed system I had to remove and attach subscriptions. I believe this is a new repo added to an existing subscription.
Comment 8 David Stadiem 2016-01-25 10:56:19 EST
This is not a sku issue. I would recommend looping in the Candlepin team. They would be able to provide insight into the issue with registering systems while introducing a new repo.

Note You need to log in before you can comment on or make changes to this bug.