Bug 1284652 - Insufficient permissions causes NPE in UserPortal extended
Insufficient permissions causes NPE in UserPortal extended
Status: CLOSED DUPLICATE of bug 1286984
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Martin Mucha
Meni Yakove
Depends On:
  Show dependency treegraph
Reported: 2015-11-23 13:53 EST by jniederm
Modified: 2016-02-10 14:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-01-05 07:15:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?

Attachments (Terms of Use)
stack_trace.txt (2.98 KB, text/plain)
2015-11-23 13:53 EST, jniederm
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49555 master ABANDONED userportal: fixed NPE. 2016-01-05 07:19 EST

  None (edit)
Description jniederm 2015-11-23 13:53:19 EST
Created attachment 1097823 [details]

Description of problem:
Insufficient permission causes that callback ProfileBehavior$2, method onSuccess() is passed empty list which causes NPE at line 

managementNetworkName = Linq.findManagementNetwork(clusterNetworks).getName();

Version-Release number of selected component (if applicable):
4.0 master, commit 47337ae

How reproducible:

Steps to Reproduce:
1. In webadmin: create vm with disk
2. Create template of that vm
3. Add new user grant him (only) following permissions
     * VmCreator for template created in step 2
     * VmCreator for some Cluster that is in DC that is in state 'UP'
     * VmCreator for Storage Domain the disk of the template is located at
4. In UserPortal extended: log as newly created user
5. Open New VM dialog

Actual results:
Exception is thrown to browser console, pink popup in UI

Expected results:
New VM dialog is open and/or user is notified that permissions are insufficient/set in a wrong way.
Comment 1 Alona Kaplan 2016-01-05 07:15:39 EST

*** This bug has been marked as a duplicate of bug 1286984 ***

Note You need to log in before you can comment on or make changes to this bug.