This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286984 - Uncaught javascript NPE when attempting to Edit VM
Uncaught javascript NPE when attempting to Edit VM
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Tomas Jelinek
Petr Matyáš
:
: 1284652 1293294 (view as bug list)
Depends On:
Blocks: 1213937
  Show dependency treegraph
 
Reported: 2015-12-01 04:44 EST by Tomas Jamrisko
Modified: 2016-02-18 06:17 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-3.6.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:17:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tjelinek: ovirt‑3.6.z?
rule-engine: planning_ack?
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50653 master MERGED userportal: NPE if the user does not have access to management network 2015-12-18 03:26 EST
oVirt gerrit 50667 ovirt-engine-3.6 MERGED userportal: NPE if the user does not have access to management network 2015-12-19 15:16 EST

  None (edit)
Description Tomas Jamrisko 2015-12-01 04:44:38 EST
Description of problem:
When using IE11 on Win7 x64 opening the Edit VM windows in User Portal results in a warning about uncaught exception:

Tue Dec 01 10:38:48 GMT+100 2015 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
Tue Dec 01 10:38:48 GMT+100 2015 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
Tue Dec 01 10:38:48 GMT+100 2015 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
Tue Dec 01 10:38:49 GMT+100 2015 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
Tue Dec 01 10:38:49 GMT+100 2015 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
Tue Dec 01 10:38:49 GMT+100 2015 
SEVERE: Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 description: Unable to get property 'q' of undefined or null reference
 number: -2146823281
 stack: TypeError: Unable to get property 'q' of undefined or null reference
   at HNm (Unknown script code:8163:534952)
   at VEk (https://rhevm36.spice.brq.redhat.com/ovirt-engine/userportal/B0BE9D9C2253E1EAC7BBA69F1585C1BC.cache.html:6036:43)
   at YEk (https://rhevm36.spice.brq.redhat.com/ovirt-engine/userportal/B0BE9D9C2253E1EAC7BBA69F1585C1BC.cache.html:6323:364)
   at OIk (https://rhevm36.spice.brq.redhat.com/ovirt-engine/userportal/B0BE9D9C2253E1EAC7BBA69F1585C1BC.cache.html:4585:36)
   at RIk (https://rhevm36.spice.brq.redhat.com/ovirt-engine/userportal/B0BE9D9C2253E1EAC7BBA69F1585C1BC.cache.html:6323:24798)
   at MHk (https://rhevm36.spice.brq.redhat.com/ovirt-engine/userportal/B0BE9D9C2253E1EAC7BBA69F1585C1BC.cache.html:5852:159)
   at PHk (https://rhevm36.spice.brq.redhat.com/ovirt-eng


Version-Release number of selected component (if applicable):
rhevm-userportal-3.6.1-0.2

How reproducible:
100 %

Steps to Reproduce:
1. use IE 11 to edit a VM

Actual results:
You get the warning

Expected results:
The exception should be handled

Additional info:
it was working fine on one of the previous builds, so this appears to be a regression. 
The system was updated between builds instead of freshly installed
Comment 1 Einav Cohen 2015-12-02 07:46:19 EST
- It looks like an application-level exception, so I assume this happens on all browsers (worth confirming) - the reporter simply happened to use IE11 -> changing summary accordingly, moving to 'virt'. 

- May be related to (or duplicate of) bug 1286224.
Comment 2 Tomas Jelinek 2015-12-17 04:07:50 EST
This is a different bug than 1286224 - this happens when the user does not have permission to see the management network, than it fails on NPE in Linq.findManagementNetwork(clusterNetworks).getName()
Comment 3 Alona Kaplan 2016-01-04 13:13:27 EST
*** Bug 1293294 has been marked as a duplicate of this bug. ***
Comment 4 Alona Kaplan 2016-01-05 07:15:39 EST
*** Bug 1284652 has been marked as a duplicate of this bug. ***
Comment 5 Petr Spacek 2016-02-01 07:24:53 EST
I confirm that version 3.6.2.6-0.1.el6 fixed the problem in our environment.
Comment 6 Petr Matyáš 2016-02-09 07:13:56 EST
Verified on 3.6.3-1
With Win7 x64 and IE11

Note You need to log in before you can comment on or make changes to this bug.